My (unrooted) Moto G4 currently has a 32Gb SD card formatted for internal storage. I can open files stored on the SD card (e.g., pictures, ebooks, etc.), so as far as I can tell the card itself is working fine. However, whenever I attempt to download a file in Chrome I get the following error: "download failed missing SD".

I thought this might be a problem with Chrome so I removed and reinstalled the app, but that didn't solve the problem. I also ejected the SD card, and then later remounted it, but I still got the same download error each time. It was at this point I realized that I can't save any new files to my phone. I can open old pictures, but I can't take a new one with my camera app. I can open old documents, but I can't save a new one in the Microsoft Word app. I even tried restarting in safe mode and I'm still having the same issue. The only thing I can download are new apps from the Google Play Store. Bizarrely, I can move apps from the SD card to phone storage, but not the other way around.

I've combed online forums and talked with Motorola tech support, but nothing has helped so far. Any help would be much appreciated.


I finally managed to solve the problem. Although ejecting the card did not work, choosing "forget SD" in the storage options solved the problem immediately (fair warning to others, this did delete all data on the SD card). It seems that although I was able to access files on the SD card, it had still become corrupted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.