1

I've had a new Pixel 2 XL for a few days now. Today when I plug it in to a PC the PC detects that it is present but doesn't show the list of files present on the device.

When I did this a few days ago, I had a similar experience, but a notification popped up on the phone asking me what mode I wanted to use. It was set to "recharge" by default, but when I changed it to "file sharing" (exact wording might not be right) the files appeared in the browser on my PC.

Today there is no notification. I have tried unplugging the device and plugging it back in several times. Did I do something to disable the notification? How can I re-enable the notification or better yet set it so that it always turns on file share mode when I plug it in?

1

Do you have a lock-screen enabled on it? Most Android phones will require you to unlock it before it will connect to the file system. If you don't have a lock-screen, you may want to check out this article and make sure it's set to file mode, and mot just MTP or charging.

  • I believe the feature is buggy. You nudged me in the right direction. From the article you linked, the "Select USB Configuration" dialog is the one I need. However, it is set to MTP but fails to operate unless I tap the MTP option again, then it works. I even unplugged and reverified that. The setting says MTP, I plug it in, the Pixel 2 XL shows up in the browser but no files, I tap the MTP option again (even though it is already selected) and then the files appear in the PC. I hope they fix that! – Octopus Feb 16 '18 at 21:14
  • The comments under the linked article (which is for Android 6) indicate that the MTP setting doesn't stick for many users. I am on Android 8 and it still isn't fixed. I guess we can forget it about it ever being fixed. – Octopus Feb 16 '18 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.