2

The Kyocera Dura XE is a flip phone running Android Lollipop 5.2. I've enabled developer mode, usb debugging and all the "verify stuff" options are unchecked and "Unknown Sources" is on in Security Settings.

Basically, I've done all the stuff there is to do on the phone. When I try to install an apk from file, on the phone I get "Install Blocked" and when I try to install an apk from adb, I get

Failure [INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES]

and logcat shows the following

D/AndroidRuntime(13719): >>>>>> START com.android.internal.os.RuntimeInit uid 2000 <<<<<<
D/AndroidRuntime(13719): CheckJNI is OFF
D/AndroidRuntime(13719): Calling main entry com.android.commands.pm.Pm
I/ProcessStatsService( 2524): Prepared write state in 5ms
D/DefContainer(13606): Copying /data/local/tmp/playstore.apk to base.apk
I/ProcessStatsService( 2524): Pruning old procstats: /data/system/procstats/state-2018-02-16-22-14-21.bin
W/PackageManager( 2524): COMPARE_PACKAGE SIGNATURE UNKNOWN : android.deviceadmin.cts
W/PackageManager( 2524): COMPARE_PACKAGE SIGNATURE UNKNOWN : com.android.cts.verifier
W/PackageManager( 2524): COMPARE_PACKAGE SIGNATURE UNKNOWN : com.android.cts.robot
E/PackageManager( 2524): checkKCSignature error
I/art     ( 2524): Explicit concurrent mark sweep GC freed 195715(8MB) AllocSpace objects, 6(1631KB) LOS objects, 33% free, 9MB/13MB, paused 1.506ms total 120.970ms
I/art     (13719): System.exit called, status: 1
I/AndroidRuntime(13719): VM exiting with result code 1.

I've resigned the packages and still doesn't work, I can't even install a hello world app I build myself in Android Studio. Kingroot doesn't work (yet, although I've read forums where it has worked). It seems like ATT has got this thing very locked down.

All I really want to do is put a couple scripts on the thing to download podcasts for me (which is all I really miss from giving up my "smart" phone), so maybe I'll ask another question if this one is unanswerable. But, what's up with this phone.

I've read almost every deadend forum post, tutorial and guide you're gonna get by binging it or googling it or searx'ing it or duckduckgoing it.

I'm not sure how to get it into fastboot mode either, it's not vol-down + power (I did wind up in 'safe mode' once, but I don't know what that is)

What I really want is to know where I can get more debug information so I can figure out why it doesn't want to install any APK files.

  • You are not alone. I want to install maps on mine. Please let us know if you will succeed at this. – whatever Jun 7 at 0:20
  • I still haven't figured anything out, but I haven't tried much lately - Kingroot still isn't supporting it FWIW. – Peter Turner Jun 7 at 5:07
2

You'll get more information about your problem by using:

adb logcat -v * > mylog.txt

you'll find the file mylog.txt in the directory where you've executed the adb command. (you can share it to help you figure out what's the problem)

The problem is:

The same package name (APK) exists on Android device with different signature. When you try to install the same package (APK) again signed with a different signature:

Example: The first APK was signed with Debug keys, then the APK you're trying to install is signed with Release keys

The solution is:

Uninstall the old package (APK) manually from Settings> Apps

or from the CMD shell, run:

adb uninstall your.package.name

  • 1
    Thanks a lot, I added the relevant info from logcat, the package I wanted to install wasn't installed on the machine to begin with - this phone pretty much won't let me install anything on it. Now, that's pretty much as advertised, but it is an android phone (albeit a flip phone) so I figured it would be easier to work around the security features.. – Peter Turner Feb 18 '18 at 23:08

protected by Community Jul 31 '18 at 20:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.