1

I use a RedMi 3S phone, with MIUI 9.2.2.0 (Malmiek; based on Android 6.0.1). I don't use a Google account on my phone so I can't (and don't want to) use the Google Play Store. I use APKPure instead.

Recently I've been getting messages from some apps - Google apps mostly - saying that they won't work unless I upgrade Google Play Services. Yet - APKPure suggests my version is up-to-date. There are also no MIUI system updates available from my phone (checked using the preferences interface).

My current Google Play Services version is 11.5.09 (446-164803921).

Questions:

  • Should I be getting this message?
  • Should I upgrade Google Play Services? If so, to what version exactly, and won't it cause trouble with MIUI?
1

Yes, that message is valid as your Google Play Services (GPS) version is relatively out of date (current version is 12.2.17). If you need to use the applications that require you to update GPS, then your only option to remove that message is to update.

The easiest way to update your GPS is to follow the notification. If for some reason that doesn't work for you, APKMirror has all the GPS variant here. The APKMirror route does require you to know a fair bit about your phone though to find the correct variant.

  • I can't follow the notification, because it takes me to the Google App Store and asks for me to login to my Google account. – einpoklum Feb 23 '18 at 8:40
  • @einpoklum in that case, it seems like the APKMirror route would be best for you then. – Mitch Feb 23 '18 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.