4

Instead of the preinstalled "Launcher3" I'd like to use "Microsoft Launcher" – but when I choose it as default, it only lasts until reboot. After reboot "Launcher3" is again set as default.

How to keep a launcher after reboot? Where are such things stored in general?

(Android 5.0.2 - API 21)

EDIT:
My Phone is a Medion X5004.
I tried via the settings menu in MS-Launcher, and via system settings.

EDIT2:
I tested installing "Apex Launcher" and set it as default - also resets to Launcher 3. So it doesn't seem to be specific to MS-Launcher.

EDIT3:
MS-Launcher does not sit on SD-card.

EDIT4:
Wiping cache has no impact...

EDIT5:
Tried to chmod 440 /data/system/users/0/package-restrictions.xml while launcher set to MS-Launcher - after reboot the file has write permissions again and Launcher3 "greets" me.

migrated from superuser.com Feb 21 '18 at 23:49

This question came from our site for computer enthusiasts and power users.

1

Not really an answer – but problem does not occur after factory reset.

0

Here's something to try:

Go into settings → apps. In the menu, select show system apps → launcher3 → set as default → clear defaults.

When you go back to your homescreen, it will let you choose your default one. Choose Microsoft launcher as the default.

Reboot your phone, and see if it helped.

Edit:

If the Microsoft launcher is stored on your SD card, move it back to the internal memory, that should fix it.

  • Thank you for your reply. Unfortunately still same behaviour. – kai-dj Feb 22 '18 at 1:46
  • This might be on Samsung device only, but try and see if you have it. Settings > default applications > home > Microsoft launcher. – aBochur Feb 22 '18 at 2:43
  • Also see if the edit is relevant – aBochur Feb 22 '18 at 3:04
  • TY again :) MS-Launcher is not installed on SD-Card. I only got Settings -> "Homescreen/Desktop" (not 100% sure about the exact word, translated from german…). – kai-dj Feb 22 '18 at 10:44
  • Try wiping system cache don't worry, this will not clear your data. – aBochur Feb 23 '18 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.