I've just setup a wifi router to use with an audio device which is controllable by Android devices through LAN. This router is expected to not have an internet connection - its sole purpose for me is to route the local network and enable the controlling via my Android phone.

However, my phone (a Moto G5S, with Android 7.1.1 installed) simply refuses to connect to this router - even though I can perfectly connect to it from a laptop. I even removed my other routers from my phone, to prevent it from jumping to wifi connections that have internet, but it still doesn't connect to this "offline router".

Now, a bit of a plot twist: I did see a notification about the wifi connection not having access to the internet, but I simply swiped it off. I tried connecting with my wife's Android, and, instead of swiping off the notification on her phone, I clicked it and I saw that it offered the option to stay connected even without internet. However, I can't do this on my Android anymore, since I got rid of that notification. Yeah, I feel stupid, but, in my defense, I had no idea that ability would be only available there. I even tried "forgetting" the wifi connection and re-entering the password, but it just won't show me that notification anymore.

So, any ideas of how to fix this, guys? How can I force the connection to my internet-less router, or, alternatively, how can I force my Android to show my the notification about "wifi offline" again?


My Solution:
Somehow, after a series of deletions, restarts, and retries to connect, the notification popped up again. I have no idea why it happened this way, but at least now I can stay connected to that router, which is what I needed.

  • 1
    Someone already edited for me, but I accepted the answer below. Sorry for the hassle. – diogobaeder Feb 23 at 3:27
up vote 0 down vote accepted

Try deleting the connection. You can do this by Settings -> Wifi -> hit the : on the top right, Saved Networks, select your router's name, then FORGET.

  • It just showed my the notification. I don't know what happened, but after multiple attempts to delete the connection, restart my device, retry to connect, it just got back to me, and then I clicked it and chose to stay connected without internet. Yay! :-) – diogobaeder Feb 22 at 1:34
  • @diogobaeder you can press on the ✓mark next to the answer. This will let other know that the issue was solved – aBochur Feb 22 at 2:36

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.