4

Samsung Galaxy S7, stock Android 7.0

I have the Meetup app installed.

If I go to App settings → Meetup → Set as default → App links:

  • Go to supported URLs is set to "Via this app".
  • Supported web addresses lists meet.meetup.com among others.

In Gmail, I click a link that starts with https://meet.meetup.com/wf/..., and... it opens in Firefox, not in the Meetup app.

How do I get it to open in the correct app? It's super frustrating that my settings are being ignored.

Then, after it loads in Firefox, I have an Android icon in the address bar, indicating that it can open in a native app:

Android icon that indicates the URL can be opened in a native app

I click that icon and... it opens a new tab in Firefox.

I tried the Open Link in App app, and the link... still opens in Firefox, without asking me which app I prefer.

I tried the Open Link With... app, and allowed Usage Tracking. I Share link and send it to that app, and it gives me the option of whether to open in Meetup or Firefox. I select "Meetup / Always", it says

Opening link with Meetup

and then... opens in Firefox.

Jackie Chan WTF??

  • @beeshyams If I open Meetup app settings → Set as default, and change "Go to supported URLs" to "Ask always" it still opens in Firefox. – endolith Feb 22 '18 at 16:53
  • 2
    Wondering if it is app specific issue or settings not working universally. Latter can be verified by say forcing Maps app to open in a browser when you click a link (by selecting Don't open in this app. If Maps (or any other app) respect your choice, issue is with this particular app else settings have gone wrong and I don't know how it can be fixed. Last resort is to use an app like this . You will fund this app recommended on this site for like situations – beeshyams Feb 22 '18 at 17:06
  • 2
    Could it be that the Meetup app can't handle the link so is silently redirecting you to Firefox? If you open the Meetup app directly, does it say anything worrying, such as that you're not logged in? – Dan Hulme Feb 22 '18 at 17:07
  • @DanHulme The Meetup app itself works fine and I'm logged in, but maybe you're right and it can't handle that specific URL even though it is registered to handle the domain. I'll experiment with other apps later. – endolith Feb 22 '18 at 17:13
  • @DanHulme You might be right. I installed Better Open With, and it pops up asking me if I want to open in Meetup or a selection of browsers, I select Meetup, and then it immediately pops up a second time asking me which of the browsers to open with, with no Meetup option, as if Meetup app is trying to open the browser. – endolith Feb 22 '18 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.