1

My device is a LG H440n. I did use adoptable storage aka external SD card as internal storage. I had quite a few games on my phone. Yesterday it has gone into boot loop, I can't rember what I did unfornuately.

When I see the graphical UI, it says that the process system has stopped wirking and restarts immediately almost every time. Yesterday I managed to get in the menu and do the factory reset and the device was ok again. Then I got cocky, put in SD card again and now it's in boot loop again. Today It won't let me.

I cant get to the factory reset through pushing buttons on boot, either Im doing it wrong, what I doubt or the buttons are not reacting.

I tried adb then:

#!/bin/bash
echo " "
echo "Wating for device..."
adb start-server
adb wait-for-device
echo "fu "
adb -d shell stop
adb get-state
adb status-window

Tried adb again:

#!/bin/bash

adb wait-for-device

echo $(adb shell getprop sys.boot_completed)
A=$(adb shell getprop sys.boot_completed | tr -d '\r')

while [ "$A" != "1" ]; do
        sleep 1

        A=$(adb shell getprop sys.boot_completed | tr -d '\r')
        echo $(adb shell getprop sys.boot_completed)
done

echo "something"

I also used watch with adb devices

watch -n 2 "adb devices >> testt"

Nothing showed up anywhere.

What to do? Any help is greatly appreicated, I dont have the money for a new phone.

  • When you say you "tried adb", what were you trying to do with those two shell scripts? – Dan Hulme Mar 14 '18 at 13:14
  • in my understanding adb wait-for-device listens for the usb connected device to boot and then access its shell. it doesnt matter anyway, the phone doenst read sim cards anymore and I will replace ot. thanks anyway – aydunno Mar 14 '18 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.