2

So i'm having this really baffling issue. I was using CM13 before and now using CM12 and both of them are facing the same issue.

I am using Galaxy Mega i9152.

There are certain applications, that have been causing my phone to reboot upon install or launch. Previously, it was Yahoo Mail (which i have not used since), then it was some other games (names of which i don't remember) and now it is WhatsApp messenger.

I thought the problem was with the CM13 rom, so i did a clean flash ( wiped data, cache, basically everything other than internal/external storage) of CM12 (hoping to get the 'move to SD card' feature as a bonus).

But, it did not resolve the issue. I just tried to install WhatsApp on my new ROM and it restarted as soon as WhatsApp finished Installing.

This has me thinking that the issue is not with Apps, but something to do with a deeper level. I'm not an expert in Kernels or such.

So please, can someone help me out here? Any insight i can get into the issue ?

WhatsApp is really important for managing day-to-day affairs, so please help me out.

  • Does it happen even without SD card installed? If the SD card had problems and would force a reboot every time it was accessed (happened to me had to change SD card to fix). Probably the app is trying to access the SD card as a part of permissions given to it and it reboots ? – beeshyams Feb 25 '18 at 15:40
  • @beeshyams Odd, no? Failing to access an SD card should result in a warning at best, or a crash at worst. – Death Mask Salesman Feb 25 '18 at 23:14
  • Did you install the correct Gapps package, OP? – Death Mask Salesman Feb 25 '18 at 23:14
  • @DeathMaskSalesman: Odd yes, after surrendering hours trying to fix it with every trick recommended in book, discovered this, when quite by accident didn't insert SD card. It was a rooted Honor 6 , no Gapps, stock ROM and upgrading ROM didn't help. Pretty much like the situation with OP except for the Gapps angle ( which you pointed out). Changed SD, it worked fine and I am still using that SD on my current device – beeshyams Feb 25 '18 at 23:25
  • @beeshyams , can you elaborate exactly why will the App write to SD card on CM13 ? I have not adopted the card as internal storage, i have been keeping it as portable ever since my first bootloop in April 2017, read here. So without adopting the SD card as internal, there is no reason for an app to write to SD card. Do correct me if i am wrong. – Muhammad Yasir Feb 26 '18 at 16:22
1

This could solve the problem temporarily. I had the same problem with my own phone and it appears to be a material problems, many recent updates are incompatible with some phones (it is the case for wiko phones). Bypassig the play store and installing a previous update can work. For whatsapp you will need a previous version than the actual one (2.18.64), but that will be older than the 2.18.0, otherwise whatsapp won't let you start the app.

For example downloading this version and manually install worked for me: https://apkpure.com/whatsapp-business/com.whatsapp.w4b/download/164-APK

EDIT:

Now this version is considered obsolete by whatsapp too. The only way to continue using it for me was to set the date of my phone to a previous date that the date showed on whatsapp saying "This version of whatsapp is obsolete since date".

I hope this problem will be fixed later because it is unsafe to install previous versions, generally updates include bug and security fixes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.