1

So now, I just plugged my phone which is a Samsung Galaxy J2 Prime (SM-G532G), a notification pops up if I want an MTP or PTP devices, since I am charing I chose Charging on USB mode. Now when I plugged my phone that notification is nowhere in sight so I cannot change back to PTP or MTP.

[EDIT] Just like to point out one thing. I've been using this same exact cable for software development purporses so yes it is working when I use MTP and for data transfer. I just don't have the option anymore to switch from USB Charging mode to either MTP to PTP.

Any ideas?

Phone: - Samsung Galaxy J2 Prime (SM-G532G) - Android 6.0.1

Thanks!

  • Enable developer options (by tapping build number 7 times ) and from the USB related options change the default. Samsung often changes options and calls it by some other name so you may have to search – beeshyams Feb 26 '18 at 4:12
  • @beeshyams is there an option to change the Charging mode to PTP or MTP? Jesus christ where is that notification item!???!!!!?? This is frustrating. I need to change it back to MTP so I can debug. I restarted the phone and everytime I plug the phone to PC it kept on charging. – Neon Warge Feb 26 '18 at 4:15
  • See if this helps thecellguide.com/… – beeshyams Feb 26 '18 at 4:49
  • With the device in charging mode and the cable connected, go to Settings › Storage – AFAIR there's an option to enable sharing behiund the triple-dot menu. – Izzy Feb 26 '18 at 7:04
  • There is none unfortunately, what I did is I simply unplug my phone, restart my phone and I turned off and turned on my Dev option and made sure the default USB connection option is set to MTP/PTP and then I restarted my phone again. It seems to be fixed now but at the cost of such a massive frustration that such a simple option should be listed on settings menu – Neon Warge Feb 26 '18 at 7:44
0

First go this path: About Device --> Software Info --> Click to Build Number up to enable Developet option in mobile.

Then go to Setting and open this path: Developer Option --> USB Configuration --> Change mode from Charging to MTP.

0

You can reach this setting in another way by dialing *#0808#, it will take you straight to the USB Settings. Tap on AP then MTP. You may need to reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.