2

For some reason, as I activate media playback in WhatsApp or hold a call there, mobile phone controls are deactivated and the screen is blacked out until the playback, or the call ends.

This is a very unpleasant behaviour, how to deal with it? This happens also with a full charge; first I thought this would be some energy saving trick but it seems not.

It is not even possible to regulate the audio volume during that.

  • On video playback this does not happen.
  • I do not touch the proximity sensor on audio playback.

Device: Sony E6653. Androis OS 7.1.1, Kernel 3.10.84, build number 32.3.A.1.54

  • 1
    Are you covering your proximity sensor by any chance? – aBochur Feb 27 '18 at 13:28
  • @ABochur do not think so. Good point! On whatsapp call, proper control of the proximity sensor would indeed make sense to swap the mode as held on ear or not. – J. Doe Feb 27 '18 at 13:35
  • @J.Doe does the screen do the same thing when you make a regular call not in WhatsApp? – aBochur Feb 27 '18 at 13:40
  • @ABochur I can't tell as I have got a data only SIM for this device. – J. Doe Feb 27 '18 at 13:42
  • 1
    I found a solution. Will post soon – aBochur Feb 27 '18 at 16:34
2

The problem you are describing, is a result of a faulty proximity sensor.

What's supposed to happen is, when you listen to voice note or make a call, the screen will stay on, but as soon as you put the phone to your ear, the screen turns off. When the sensor is broken, it thinks that the phone is always by your ear.

One way to get around this, is by using an app called macrodroid.

You can set it in a way, that when the proximity sensor is activated while in WhatsApp, the screen will stay on.

Here are the few simple steps to set this up:

  1. Open macrodroid → add makro → sensors → proximity sensor → near → ok. Now press on proximity sensor and add each of the options separately.

  2. Press on actions on the top of the screen → screen → screen on/off → screen on (alternative) → ok

  3. Constraints → device state → application running → running in foreground → ok → WhatsApp → ok. ↠ application running → alive in background → WhatsApp → ok.

  4. Now press on the check mark on the bottom, and give a name to this action.

  5. From the main page of the app, press in macros, and after pressing on the one you just made, near constraints, press on and and change it to or. You should see the exact settings as I have below:

enter image description here

Now test this out. Go into WhatsApp and make a call. The screen will stay in during the call.

Note:

  1. The screen will stay an as long as WhatsApp is running, and it will disregard the set sleep time. It will also stay on while not in WhatsApp, as long as WhatsApp is running in the background. If that happens, you can go into your recent apps, and swipe WhatsApp away.

  2. I tested this in s galaxy s5. No guarantee that it works across all phones.

  • Upd - nice app but the maxro does not trigger. -.- – J. Doe Feb 27 '18 at 17:37
  • Does it all look like in the screenshot? – aBochur Feb 27 '18 at 17:44
  • Make sure to enable the app from settings > accessibility – aBochur Feb 27 '18 at 17:44
  • 1
    @beeshyams thanks for your input. Edited. Waiting to hear from OP – aBochur Feb 28 '18 at 2:12
  • 1
    @J.Doe it worked on my s5, so I'm not why it doesn't work by you. So I guess one thing I did help determine, is that your proximity sensor is broken, and there's why it's not working. Hope you have luck from here onwards – aBochur Mar 4 '18 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.