2

There's a strange situation with Citymapper, where it doesn't access GPS location directly, but it does if a different app is accessing location at the same time. This hasn't always been the case, but I'm not sure exactly when it started (so, can't say if it's because of a certain update etc.).

Problem details:

  • I'm using Citymapper 6.23 on LineageOS 14.1.
  • The Location permission is for Citymapper is turned on
  • "Location mode" is set to "Device only" (i.e., GPS only), although I've tried turning "High accuracy" on to test, and it doesn't fix the problem.
  • I have Privacy Guard enabled on Citymapper, but access to location is allowed, and as before, disabling Privacy Guard for Citymapper doesn't fix the problem.

Citymapper "thinks" it's accessing location, but it's not: I say this because when I disable the location marker for the device, Citymapper complains that "Your location is disabled". If location is on, Citymapper doesn't complain (so, it thinks it's working), but I know it's not accessing the location for three reasons:

  1. the location Citymapper shows is incorrect (it shows the last "known" location -- see below for details)
  2. the location marker doesn't appear at the top of the screen as it would when an app is using geolocation
  3. in the system settings > Location, "Recent location requests" are shown, but Citymapper is not on that list.

Further to this, Privacy Guard reports that "Fine location" is being accessed by Citymapper every time I use the app, but it says that GPS was last accessed on 26 December 2017 (Privacy Guard controls separately access to "GPS", "Coarse location" and "Fine location").

Indirect access:

The weirdest part is that when I open a different application that uses geolocation (in this case, MapFactor Navigator) and the location marker does show up at the top of the screen, the correct location does show up in Citymapper as well (this is my current workaround, and this is how Citymapper gets the last known location I mentioned above).

What could be causing this, and how could I go about fixing it? As I've mentioned, it used to work but started having this problem a while back (perhaps around the 26th of December, since that was the last GPS access). I haven't seen this with other apps, but then again, I don't have a lot of apps with location access.

System details:

  • Device: Samsung Galaxy S5 Duos (SM-G900FD)
  • OS: LineageOS 14.1
  • Android version: 7.1.2
  • The phone is rooted with SuperSU.

Note: There's no "Citymapper" tag (and I'm a newbie), so I used the generic "applications" tag. Maybe a senior user can fix this.

2

Android Engineer at Citymapper here!

The issue you're describing sounds quite similar to one we fixed recently. So I would recommend updating to the latest version of the app. The current version in the Play Store as of writing is 7.1.

  • Thanks, @ted-eriksson! Works now. I was assuming that Play Store was letting me know when updates were available, so I didn't even think to do this (most basic) check. I guess you know what they say about "assume"... – Ratler Mar 1 '18 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.