2

I have been trying to figure out what is limiting my lan transfer speeds. I have openwrt/lede on my linksys router, and a samba server running on it with a usb hdd plugged in.

My last device, a M8s Pro was transferring at kilobytes a second across the lan (see post here for more details)

I also have a Nvidia Shield tablet and a newly purchased Leelbox Q3 box. On these the lan transfer speed is about 3.5 to 4.5 mb/s

Which is alot better but my laptop gets around 20 to 40 mb/s

What is the problem here, why cant I reach speeds similar to my laptop on these android devices? Is it hard drive write speeds or the wifi chips in them?

I ask because I want to return this leelbox and get something that is going to be comparable to my laptop.

  • How do you connect the phone to the LAN? Are you using an USB to Ethernet adapter? – Volker Siegel May 18 '18 at 22:46
  • its an android tv box, it has an ethernet port built into it – owen gerig May 18 '18 at 23:01
1

Im not 100% this is my final answer however after further searching I found that there is no SMBv3 support till Oreo and some suggested to try FTP.

So I installed FTP on my openwrt and tried that for transferring files. Now instead of 3.5 to 4.5 mb/s, Im getting 7mb/s which is almost double and better then before but still not the speeds I see on my laptops (using 5ghz wifi).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.