2

My wife's Pixel just started behaving oddly this evening. Virtually all Google related services keep force closing with the error message "_____ has stopped" or "_____ keeps stopping". There are various different apps and services that fill in the "blank".

  • Google
  • Settings
  • Google Play Services
  • Device Health Check
  • Google Keyboard

Additionally other Google apps, such as Google Maps, do not launch when started. It just returns to the home screen without an error message. And when she tries to open Google Play, all she gets is a white screen.

A common suggestion I've seen both here and other sites is to clear the system cache, unfortunately she is running Android 8.1 so that setting doesn't exist. Additionally because Settings force closes upon launching, I am unable to do it for the individual apps (besides, which app do I clear). Another is to reinstall the Google Play services, but I'm unable to do so because Google Play closes when I open it as well as does settings so I can't roll it back there.

Since this started all of a sudden as soon as she returned home today, I'm assuming there is a bad update somewhere, but since I can't get into Google Play or the Setting to see the app details, I can't uninstall or reinstall.

I've tried booting into Safe Mode and I get the same error messages, so that won't be a help.

There were no apps installed recently, and if it helps, many 3rd party apps and games appear to work fine.

As pointed out in the comments, a factory reset would seem to be an option, but I consider that the "nuclear option" that I'm trying to avoid since it involves a lot of backing up and restoring that I don't want to go through.

  • Factory reset? Backup data before. – MANI Mar 6 '18 at 3:13
  • @mani trying to avoid that but i assumed would be an option – psubsee2003 Mar 6 '18 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.