I'm aware of the suddenly restarts of the Galaxy Nexus, but in my case it restarts before managing to boot completely and it does that in a non-stop loop. It happened while my phone was on a stand by mode and now I can't do much, so it is basically useless.

Is there anything I can do about it. Is it possible to reset it somehow? I tried to remove the battery, charge it and all that kind of stuff that I could do, but no luck so far.

I bought it through Amazon.com and the model is Samsung I9250 Galaxy Nexus 16GB (Unlocked), but I'm in Europe so warranty is something that would take sometime I guess.

Update: I also tried to follow these instructions but my computer cannot find the device. I'm stack in the ODIN MODE, Do Not Turn Off Target if I do the trick with the volume down button, otherwise it just restarts without completing the initial colorful effect. Any ideas?


I would unlock the bootloader, and flash a new image...

You can find all the information you need on this page:


Hope you found my answer helpful :)

  • I would like to have the original Google's ROM.. I haven't go through the article yet.. but is it going to work without me being able to start the phone?
    – Lipis
    Feb 10 '12 at 14:46
  • You should be able to push the new image to the phone through fastboot mode.. If you can come in fastboot mode, its is almost always possible to save it...
    – dev0
    Feb 11 '12 at 3:42
  • 2
    And google image is possible to find here: code.google.com/android/nexus/images.html It is google which have uploaded them :)
    – dev0
    Feb 11 '12 at 3:43
  • Are you Danish? If so i can probably better help you on Androidforum DK, where i'm a mod. I have also translated the Toolkit into danish if you need it, right here:
    – dev0
    Feb 11 '12 at 4:21
  • 2
    Have you installed the drivers on your pc? The tool need the drivers, before it can recognize your device...
    – dev0
    Feb 14 '12 at 17:17

Something might have overwritten some files needed during boot.

Go into recovery and do a factory reset. Yes this is the same thing as factory reset in the Settings but the difference is that you dont need to boot the OS to do it.

There is usually a button combination you press to get into recovery. Google it for your device. Once you factory reset, try again.

WARNING: Factory Reset will wipe all user data on your device. Sorry.

If you reboot and everything is working, then it was your user data. If you reboot and the same thing happens, then that means your actual system is corrupted. This means like dev0 said, you have to flash a new image or send it in for warranty.

Just because you flash a new image, doesnt mean you cant get a stock rom image. Chances are, someone on XDA has a stock ROM image that is exactly the same system as when you first got it. People have these images in the event someone wants to go from a custom ROM or version of Android to stock.

So yeah, follow dev0's links and advice. Rooting and unlocking the bootloader might void your warranty so find out before you do it though!

  • Can't do much.. the phone is not recognized by the computer :( read my last comment from dev0's answer
    – Lipis
    Feb 14 '12 at 13:43

Hmm I just googled this. It doesn't help but helps me :) Now I wont do a default factory setting on my Galaxy Nexus. Clicky.

You can try this page if it has the same functionality as Samsung Galaxy S

  • Nope.. no help ;)
    – Lipis
    Feb 7 '12 at 17:48

Do you use Cyanogen ROM? If so, try other roms such as MIUI. I had this problem exactly as you on my Nexus S with Cyanogen and after migrating to MIUI all the reboots, booting animation loops, shuting downs on standby and etc. gone.


I have a similar issue with my Galaxy Note after installing a lot of apps and filling up the 32GB SD card. I haven't managed to figure out what exactly the problem is, maybe it is totally different (since there are different Android versions).

Anyway, I'd start by removing the SD card, but Nexus doesn't have a removable card slot...

If you're using stock ROM, check out if there's an updated version of your ROM available. Search xda-developers forum, it may have a thread that lists all stock ROMs available for your device.

Some of the stock ROMs are "wipe" and others are "non-wipe". You can try flashing non-wipe stock ROMs on your device and see if it fixes the issue. (you don't need root or custom recovery for this, if Nexus works the same way as my Note). But anyway, I'd recommend making a nandroid backup before doing so.

If you have USB debugging enabled already, you might be able to get the system logs from a PC, if the phone gets to the point during the boot that can connect to adb. But if you don't have the USB debugging enabled, since you can't boot and go to settings, this won't work. If you could get logs of the system, it may give you a clue of what is causing the phone to restart.

If it didn't fix the issue, I think your only option is to boot into recovery (hold power + home + volume for 10 seconds or so) and do a factory reset.


I have exactly the same problem with my GN and followed the instructions in http://support.sprint.com/support/tutorial/Perform_a_hardware_factory_reset_Galaxy_Nexus/37165-396 Please note that all of your data will be deleted.

  • You've followed those instructions and still have the problem? Or did those instructions solve it? In the latter case: it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies.
    – Izzy
    Jun 10 '14 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.