I installed Lineage 14.1 and then flashed: open_gapps-arm64-7.1-full-20180303.zip on my rooted ZTE Axon 7.

I let the phone do all the updates and checked the permissions for Gmail, Calendar, and Contacts and they seem set properly; however, in Gmail, the addresses of known contacts don't populate on a new email or forward. Similarly the Calendar won't let me choose invitees for a meeting. Contacts and Calendar are properly synced.

I subsequently deleted my Google account and all its data and reflashed Gapps again. This forced Gmail to ask if I wanted auto suggestion (or auto complete). When I tried to click on the option, it feels like it never allowed me to complete the selection. In the app permissions Gmail has access to contacts, and no amount of selecting or unselecting does anything. I can choose to i"add from contacts," but this is very clunky.

I consider the lack of autocomplete for Gmail (and calendar) enough that I might have to nuke the device and go back to stock.

I have googled to find a solution, to no avail. I've also searched the forums. Any ideas?

1 Answer 1


To fix this, I deleted my Google account from within Lineage OS. I then downloaded the Aroma of Gapps and pushed it to my device. Rebooted into TWRP and wiped cache/dalvik cache and then flashed the new version of Gapps. Aroma allowed me to exclude whichever Gapps I no longer wanted and I then rebooted.

I double checked that both Gmail and Calendar both had permissions to access contacts, but thankfully this process brought back auto suggest.

P.S. there was an issue with contact syncing all the way, whereby I was given the dreaded "Sync Is Currently Experiencing Problems" message. I used the Contacts Sync Fix app in the Play store to remedy this (it worked). It discovered a malformed contact with illegal characters in the notes field (this may ultimately have been the problem in the first place).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .