0

Like the title says, resetting the Play Store to its factory version caused it to be stuck on version 7.8.16.P. Tapping the update button downloads an update but then it doesnt change anything.

The phone is a Samsung Galaxy J7 Prime updated to Android 7.0 from 6.0 through official updates. The device is not rooted.

Has anyone experienced this problem or know of a way to fix it?

3
  • Try clearing its app data also the google app. But it may ask for you to sign in again
    – arthur kay
    Mar 14, 2018 at 21:50
  • Tried that, it remains stuck on the same version.
    – Aeder
    Mar 15, 2018 at 3:17
  • Tried instaling via an apk? Its not recommend but then its worth a try. Play store may be acting as if its already updated
    – arthur kay
    Mar 15, 2018 at 8:07

1 Answer 1

0

Turns out the refusal to update is because my ISP is issuing awful modems that start having issues after prolonged use, like dropping connections to Google services.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .