0

I need to share wifi connection from my Moto to iPhone over Bluetooth with minimal or no manual interaction on Moto G.

How can I make Bluetooth Tethering always enabled (On) at a LineageOS 14.1 device?

Alternatively, how can I setup Tasker script to enable Bluetooth tethering on Moto G 2nd gen LTE (XT1079), running LineageOS 14.1 (build 20170922)?

1

Automate can do so using its Bluetooth tethering set state block, no additional plug-ins required.

  • Thanks, it just works! And Automate's in-app search across user-submitted recipes is awesome! – yurkennis Mar 19 '18 at 18:28
0

Additional requirements:

  • Secure Settings

    Task

  • Go to the Task tab and select "New Task + "

  • You can name this Task AutoBluetoothTether or anything.
  • Click "+" to add new Action
  • Plugin → Secure Settins → [Configuration: Actions → BT Tether] → On (Tick Automatically Enable Bluettooth option)

Be sure to pair your Android device with Iphone (via bluetooth) prior and also you can set your profile to react to wi-fi connection i.e State → Wi-fi Connected (set SSID)

  • Tasker lists "BT Tether" as disabled option. When trying to enable it in Secure Settings, it says "This feature requires a Bluetooth tetherable interface. – yurkennis Mar 19 '18 at 13:00
0

The Automate block doesn't work on my device (Android 8.0, MIUI 9). And the Tasker solution requires a non-free plugin Secure Setting.

Run this(root required) to enable bluetooth tethering:

service call connectivity 24 i32 2 null i32 0

It calls startTethering(), while 24 represents startTethering and 2 represents TETHERING_BLUETOOTH.

Tested on Android 8.0. You can check the interface definition(aidl) for your version if it didn't work on older devices.

  • Sounds promising. How can I find out "the interface definition (aidl) for my version"? – yurkennis Dec 10 '18 at 22:16
  • @yurkennis Switch the branch of platform_frameworks_base(link above) to your version(e.g. nougat-release for Android 7). – hrmthw Dec 11 '18 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.