2

I want to install a module (bcm4329.ko) in my nexus one phone. I have rooted the phone and installed Cyanogenmod too.

In Terminal emulator, I tried various commands but everything resulted in failure

$ insmod /system/lib/modules/bcm4329.ko //[Operation Not Permitted]
$ su insmod /system/lib/modules/bcm4329.ko //[throw the syntax/man page of su]
$ cd /system/lib/modules
$ chmod 777 bcm4329.ko //[Read only file system]

The error messages I received are enclosed within '[ ]' after every command. How can I install this module in my android phone. Any help please.

1 Answer 1

3

You need to remount the system partition as read-write, it's read-only by default.

mount -o remount,rw /dev/block/mtdblock3 /system
4
  • Got the error "mount: permission denied (are you root?)" Is there any other way to give root permission, as I already have rooted the device.
    – SyncMaster
    Feb 10, 2012 at 4:39
  • @SyncMaster Did you type su in the terminal first? Feb 10, 2012 at 4:40
  • android.stackexchange.com/questions/4021/… solved it. thanks. :)
    – SyncMaster
    Feb 10, 2012 at 4:40
  • @SyncMaster Lol good timing. Feb 10, 2012 at 4:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .