I am trying to install an application (developed using Eclipse) onto the computer (I am using Windows XP). When I try to connect the USB cable with the phone, it starts to charge or starts the MTP application, but it does not go into mass storage mode. Here is what I have tried so far:

  1. Turned on USB Debugging and then plugged in the USB cable. Result: Phone goes into charging mode.
  2. With USB Debugging switched off, USB Utilities -> Connect to Mass Storage button pressed and the USB cable plugged in. Result: Plugging in the USB cable results in MTP application starting. Switching that off by pressing the home key and then pressing that Connect to Mass Storage button again results in the message: USB is connected. Remove the cable
  3. Tried the *#7284 routine described in thread on this forum. That did not work either. My default settings were USB -> PDA (just the way that thread said it should be).
  4. Checked if the Google USB drivers are all installed. Yes, they are. Other drives also mount from the same USB slot without any problems.
  5. Switched off and then back on the phone.
  6. Used different cables (one from Samsung and the other from Nokia) to see if there could be anything wrong with the cable. The same situation as above. And the Nokia cable is brand new.

After having done all of this and spent a grand total of five hours, I am at my wits' end trying to figure out how I can get the phone to mount as a USB storage device. I have mounted it successfully before.

UPDATE: I plugged my phone in to a Linux machine and a Windows machine using both cables today. It worked for the both of them!!! So now I know that USB storage mode on my phone works. The problem has to be with my laptop, or to be more specific, with the USB drive on my laptop. My questions now are:

  1. How do I know what USB drive make is present on my computer. I would like to re-install the USB drivers on my laptop, all the while hoping that it does not screw up my machine.
  • Sounds like it's just ignoring the setting, that sucks. I would suggest a factory reset, though hopefully there's a simpler solution. Feb 10, 2012 at 4:36

1 Answer 1


I highly recommend checking out QTadb. It is a very useful program with a file manager; you can just drag and drop across. If you have an APK on your local machine, you can install it right in the file manager. Plus there is an ADB shell built in, an app list with back up options, and a ton of other stuff.

I would say this is a must-have for an Android developer. It's just extremely useful.

I hope that helps you out.

  • Potentially useful workaround, but not really a solution to fixing mass storage mode. Feb 10, 2012 at 4:39
  • I would suggest seeing if it is possible to connect using adb (or QTadb) and to browse the drive. I have an sgs2 and i had a problem with it not mounting. I used qtadb and that magically fixed the issue, i imagine mostly because it remounted it with adb. Feb 10, 2012 at 4:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .