0

I have HTC One (M8). I just found out that the model on the back of the phone is 0P6B100 while it's 0P6B700 in getvar. I found that out after trying all the x.xx.651.x RUUs flashed down below because I thought it needed Sprint RUU.

First of all, every time I reboot I find the same apps installed, pics, and missed calls no matter how many times I erase all that, and if I installed new apps, every reboot it's not there. I wanted to get it back to stock as new but I couldn't and here is what I have tried:

  1. Couldn't flash stock or custom recovery. Got [failed (Remote : Not allowed)] because the bootloader is locked, and I couldn't unlock the bootloader. After getting unlock code from HTCdev.com and installing it and after selecting yes on the phone to unlock the bootloader, the phone just reboots.

  2. Tried to flash RUU (3.30.651.2 & 4.25.651.14) wizard while the phone was on fastboot mode. Phone couldn't boot into bootloader while on fastboot mode so it reboots regularly.

  3. Tried to flash RUU (3.30.651.2 & 4.25.651.14) wizard while the phone was on. Did the first steps and it was ok, but again, when the wizard is waiting for the bootloader while phone was in fastboot mode, it just reboots regularly.

  4. Tried renaming another (4.25.651.14) RUU to 0P6BIMG.zip and put it on SD card and went to Hboot. After clicking yes to confirm the update, the phone rebooted in the middle of the steps.

  5. Tried flashing the same 0P6BIMG.zip from recovery mode. After 3 minutes of hope crushed by verifying update package.... - Installation aborted....

6 Tried flashing RUU.zip via fastboot. The phone just reboots regularly when trying to reboot RUU.

Here is the result from getvar:

version: 0.5
version-bootloader: 3.18.0.0000
version-baseband: 1.08.20.0612_4
version-cpld: None
version-microp: None
version-main: 3.30.651.2
version-misc: PVT SHIP S-OFF
imei2: Not Support
meid: **************
product: m8_whl
platform: hTCBmsm8974
modelid: 0P6B70000
cidnum: 11111111
battery-status: good
battery-voltage: 0mV
partition-layout: Generic
security: off
build-mode: SHIP
boot-mode: FASTBOOT
commitno-bootloader: d4c3cae5
hbootpreupdate: 11
gencheckpt: 0
----------HBoot Menu----------
* Locked *
M8_WHL PVT SHIP S-OFF
CID-11111111
HBOOT-3.18.0.0000
RADIO-1.08.20.0612_4
OpenDSP-v38.2.2-00542-M874.0311
OS-3.30.651.2
eMMC-boot 2048
Jul 7 2014,20:03:18.3

I want to erase everything and start over with any ROM or any recovery.

0
0

You will need to unlock the bootloader of your m8 before being able to flash any RUU or custom ROM on it.

In order to do that, I suggest you to visit the XDA forum for the m8 - bootloader threads (XDA is clearly the best site for anything phone related), and try to find one of the many ways to do it that suits your phone and its current state (you might have to change the bootmode - it is now on fastboot).

Best of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy