0

I just don't know how to fix this issue. I have tried almost everything and give up. I have read other threads on what to do if there is .thumbdata3 file that occupies a lot of space. my file occupies almost 20 gb and I cannot afford that space waste. I have done the following to try and circumvent but nothing works

  • create an Empty file with the same name. that empty file will eventually increase to the same size

  • stick a .nomedia file in every folder that contains an image so this file does not grow in size. and then I repeated the above first... the file is still created. there are some observations have had in that regard.

  • initially the dummy file I created remains as it is. then as soon as I try and open or call in Explorer through some third party app for example there is an app that needs of photo to upload so Explorer is invoked through the app to choose the photo the phone then completely freaked out and Will hang and forces a reboot

  • why this hung state happens I open up process monitor which unlike other apps will run regardless of how hung the phone is... I find the process download manager and under that the process name is android..process.media this process strikes out as the highest CPU consumer. and within a matter of minutes the hounded 20 gig .thumbdat3 file is back. I am rooted on an Xperia Z3 Running Android 6.0. another thing that I observed -if I use any third party app that is supposed to let me CHMOD and C H O W N even though an attempt to remove write permissions. for everyone, will run without errors the file permission will remain the same they will not change. dytto experience when you use terminal emulator and SU on the prompt Process Manager screenshot I wonder

    -if I disable manual this process

    android..process.media

then what happens.

  • why is it that in spite of sticking in a ..nomedia file in each and every folder in spite of that the process will build the 20 gig file.
  • "create an Empty file with the same name" – well, that will just be used then. Try creating a directory with the same name, that should work if you want to get rid of the thumbs completely. – Izzy Mar 18 '18 at 9:41
  • no actually .thumbdata3 file is created within ` .thumbnails` directory ... so creating a directory with the same name will not help. I will try creating a file by the name of the directory I don't know if that would help I have to check it out – user1874594 Mar 18 '18 at 9:46
  • Then create .thumbnails/.thumbdata3 as directory. If you insist on trying with a file, at least make that read-only. – Izzy Mar 18 '18 at 9:49
  • I tried to mess around with octal as an su... that is one of the questions I asked in here..... even as SU I cannot change them – user1874594 Mar 18 '18 at 9:50
  • I've never tried that, but a raw idea: the reason behind that most likely is the "FUSE" system used here. Assuming we're talking about /sdcard: that's just a "symbolic link" pointing to a different place. Maybe you can change file permissions at the "real location". Note that can be multiple "hops", the symbolic link pointing to another symbolic link. On my device, /sdcard points to /storage/self/primary which then points to /mnt/user/0/primary which points to /storage/emulated/0. The latter then is the "real location". – Izzy Mar 18 '18 at 9:57
0

in my case creating an Empty file with the same name works and this problem as since then disappeared. so a trick is to create thumbnails file after you delete the folder by the same name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.