1

I have an Huawei Ascend G620S-L01 with Android 4.4.4 and EMUI 2.3. I'd like to make a full backup of the system in case something goes wrong when I try to root it later, so that I have a safe backup to restore to.

I enabled USB-Debugging in the phone's Developer Option and chose a password for the backup.

Then I got myself Android Studio and installed the Google USB Driver with help of the SDK Manager.

In the CMD I went to C:\Users\NAME\AppData\Local\Android\Sdk\platform-tools.

I connected my phone with my PC, chose the USB mass storage mode (though MTP doesn't make any differences, I tried that too). When I choose the option that the phone should just load, it won't even be recognized by adb devices.

Now, when I enter adb devices it shows my device, at least it gives some digits and letters on the left and it says "device" on the right.

Now I enter: adb backup –all -apk -shared –f c:\backup\backup.ab I also tried adb backup '-all -apk -shared -f c:\backup\backup.ab'

The answer is the same: Now unlock your device and confirm the backup operation...

But on my phone, nothing happens. No dialogue appears.

C:\backup just shows a file with 0KB named backup.ab

CMD shows again that I'm in my platform-tools folder and waits for a new order.

I also tried using adb-1.0.31-windows, didn't change anything for me.

I hope someone can help me and guide me into making a full backup.

Thanks in advance for your support!

  • When you plug the phone in by USB, does it show the notification that USB debugging is enabled? – Dan Hulme Mar 19 '18 at 14:14
  • Dear Dan, thank you for your answer. Yes, my phone does show the notification that USB debugging is enabled. – Pernau Mar 19 '18 at 14:51
  • It's possible that Huawei broke the adb backup support in their firmware, but someone with more knowledge of Huawei devices might know better. – Dan Hulme Mar 19 '18 at 15:17
  • Alright thanks, we'll see about that soon I hope. Though I think if this was true you would find something about this issue via google, yet I don't. – Pernau Mar 19 '18 at 16:29
  • @DanHulme if the device were not in "ADB mode", the adb backup command would yield an error ("no device found"). I however second your second suggestion, as I had a similar issue on a different device some years ago where restore didn't work, so that might well be. Guess a question targeted at Huawei support would help to either confirm this or rule it out. – Izzy Mar 19 '18 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.