I can select only Sound picker as source for my own sound files when choosing ringtone. Right before I could select Google drive and some more.

How can I get the choice back?


When going Settings->Sounds and vibration->Ringtone->(+)Add from phone I got 3 or 4 choices of source. GoogleDrive, Soundpicker, ...
I picked Soundpicker just to see what it was. (but decided I don't want a Samsung app to get even more of my data) So I did the Settings->...->(+)Add from phone again but this time I could not choose any source any more but Soundpicker was automatically launched.

Is there a way to reset this setting? so I can choose, say, GoogleDrive.

Or any other way to get a sound of my own as ringtone?


All you have to do, is clear defaults for the sound picker app. To do so, go to settings → application manager (apps) → in the three dots menu, select "show system apps" → sound picker → defaults → clear defaults.

After clearing defaults, you will now be able to choose between the other options.

Oh and usually even within the sound picker you should be able to scroll all the way down, and it will have an option to choose a track from your phone.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.