1

I am trying to flash TWRP onto a Redmi Note 4X I have the device's bootloader unlocked. I tried the following: Boot into fastboot mode on the Redmi (Vol Down + Power). Then type fastboot flash recovery twrp-3.2.1-0-mido.img on my PC. It says

target reported max download size of 536870912 bytes
sending 'recovery' (26868 KB)...
OKAY [  0.625s]
writing 'recovery'...
OKAY [  0.360s]
finished. total time: 0.985s

Then press Vol Up + Power. The mi logo appears and then screen turns black and nothing happens. When I type adb devices it says

List of devices attached
8dbec68d0604    recovery

So it seems I am in recovery but nothing happens. I tried alternatively with older TWRP versions available for download. Same result. I also tried fastboot boot twrp-3.2.1-0-mido.img It says

downloading 'boot.img'...
OKAY [  0.617s]
booting...
OKAY [  0.654s]
finished. total time: 1.270s

But also same results. I can restart and load into MIUI just fine after that.

I tried this with the stock MIUI version that came with the phone, also with the latest Stable ROM and also with the latest Developer ROM. Always same result.

When I choose "Reboot into Recovery" from the MIUI Update Settings, I get to the MI-Recovery which seems to work fine.

Now I am out of ideas. Any help is appreciated. Thanks!

1

I found a thread over at xda that helped me solve the issue: https://forum.xda-developers.com/redmi-note-4/help/strange-problem-black-screen-redmi-note-t3716706/page10 Apparently it is some issue with a certain kind of display and the official TWRP can't handle it correctly. The proposed solution is to download an unofficial TWRP version found here: https://cloud.mail.ru/public/9bcY/3AeSnww5N

Hope this helps anyone with the same problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.