I am buying an Archos G9 (Android 4.0). And a Raspberry Pi. I'd like to take them along for trips, and they need to be able to communicate over a network so I can use stuff like VNC etc.

How do I do this?

AFAIK ad hoc WiFi is annoyingly unsupported on Android, but can I connect to the Raspberry Pi if I manage to set the latter up in Master Mode with a usb wifi dongle? That might be hard though.

How about LAN over bridged usb cables? Does Android support that?

Any other ways of getting a network between this device and a generic linux box? It has WiFi, Bluetooth and Usb connections.

  • I would doubt LAN would be easily doable without a custom kernel, Android has never really provided drivers or support with it. Tangentially: has the G9 received an ICS update that is not reflected on the Archos site? The model you linked to is listed to run Android 3.2, not 4.0: archos.com/products/gen9/archos_101g9/… Feb 11 '12 at 20:27
  • The makers of Archos officially stated Android 4.0 would be on G9 in February 2012, so I thought I might as well base my question about that. Also, your comment about LAN is interesting but also leaves me clueless. Surely communicating with other devices is no problem via a WiFi access point? Which methods of LAN, specifically, are you saying are not supported at all? Feb 11 '12 at 21:07
  • Sorry, I meant your idea of using a USB cable for LAN. Android has never historically supported any kind of meaningful USB networking capabilities, AFAIK. Feb 11 '12 at 21:13

I've recently bought an Archos 101 G9 Turbo (running ICS 4.03) with the intention of using it for work purposes to replace my slow Windoze netbook. The only shortcomming I though I would experience was having access to an ethernet port on the device.

I found an old USB LAN adapter that's been lying around in a drawer for a few years and out of curiosity. I thought it can't do much harm to try it. I plugged it in the the micro-usb port via a host cable and much to my surprise a grey Ethernet icon immediately popped up in the tablet's system tray. I plugged in an Ethernet cable from my network switch into the adapter and lo-and-behold it picked up an IP address via DHCP and connected to the net! No software, no configuration - true plug-and-play!

The Ethernet icon 'lights up' when connected so you can see it's good to go. The only thing I can't find is any configuration options under settings, so it looks like it might only work with DHCP and default settings (if anyone can throw any light on this It would be appreciated).

Even better, these things are still available and really cheap to buy, the host cable (micro USB male to USB A female) was GBP £1.99 and the USB ethernet adapters can still be bought for less that GBP £2.50 online. The USB ethernet adapters are available from the usual online sources. The one I have uses an SR9600 chipset if that's any help.

FWIW I've just tried this on my old Archos 7c G2 tablet running Froyo 2.3.3 and it doesn't work with that. I've tried it on a Samsung, Galaxy tab running Honeycomb 3.2 and this too doesn't recognize the device so I guess it's just ICS it works with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.