I have been searching for how to properly upgrade to new sdcard, and I did as this posts suggests. How to upgrade / swap SD card without losing data and installed apps?.

But when inserting the new sd card several apps (not all) are missing. I had about 80 apps installed, could that explain why I am having this problem, while no other seem to have it?

Could it be, that there are two partitions on the original sd card, one being used for apps when internal memory is full; and I have then only copied the part not in the 'simple' partition?

Using Gingerbread (2.3.3).

  • 1
    What's your device? Which Android OS version is it running? Are the missing apps the ones that were moved to SD Card?
    – Chahk
    Feb 13, 2012 at 14:30
  • Your SD card would have only one partition unless you or someone else rooted your phone, installed simple2ext or similar, and partitioned your card. It might be secured apps (encrypted while on the SD card) that are missing; I'm not sure if they can be migrated. Feb 13, 2012 at 19:27

2 Answers 2


I found out that all the apps missing have an .asec file in the .android_secure folder on the sd card, however the .android_secure folder itself is there.

On Linux I wrote:

cp sdbackup/* /media/disk -r

It copies all folders, and their content, recursively. Except for the hidden folders in sdbackup, e.g.:


Hidden folders in the hierarchy are copied however.

So now I managed by subsequently copying each hidden folder:

cp sdbackup/* /media/disk -r
cp sdbackup/.android_secure* /media/disk -r
cp sdbackup/.astro* /media/disk -r

And now everything is fine.

  • 1
    That's because you are using linux wrongly. First, * gets expanded by the shell, but since * does not include hidden files or directories (dot files), the .android_secure is not included. And since you use cp on /path/to/*, ie, every non-star file the shell finds inside "/path/to/", the folder is not included. The correct command is cp -r sdbackup /media/disk. This makes cp copy recursively, from the starting point of "/path/to". Notice the lack of a trailing forward slash. sdbackup/ is the inside of sdbackup. sdbackup/* is not everything in sdbackup.
    – cde
    Jan 16, 2014 at 4:25

My solution, using Windows, was to format the new card with the same file system (FAT32) and allocation unit size (in this case, 4k).

To determine allocation unit size on Windows, go to the command prompt, go to the drive letter that the new meida card is on, and type CHKDSK. Allocation unit size will be displayed near the bottom of the results.

To format, in Windows Explorer right click on the drive letter of the new card and then click on Format. It should be obvious from there. The quick format option worked for me.

As for copying files, I had no problem with hidden files. Straight copy worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .