1

I'm running in to some very strange behavior when trying to use Progressive Web Apps (PWA) after saving them to my home screen.

Every time I try to open on, the OS prompts me to install Chrome (which is already installed). I've made sure that Chrome is up to date and I have even tried remove and re-installing Chrome, but the result is always the same.

Here is a screenshot of the prompt: enter image description here

Here is a video demonstrating the behavior: https://youtu.be/yxclkaWVefc

Any help in figuring out what is causing this and how to solve it would be greatly appreciated. Thanks in advance :-)

  • Device: Galaxy S8+
  • OS: Android 8.0.0
  • Try setting Chrome as your default browser (if it isn't already), or making the home screen shortcut in Samsung Internet instead? If all else fails go with the wonderful Hermit app for adding web apps to your home screen. – owlswipe Apr 6 '18 at 5:13
  • Have you had this behaviour with more than one web app? – Dan Hulme Apr 9 '18 at 10:47
  • @owlswipe Chrome was already my default browser. I tried saving with Samsung Internet... and that does NOT have the same issue as Chrome. It works as expected in that case. I have never heard of Hermit until today, it looks pretty neat. – Maurice Apr 9 '18 at 19:25
  • @DanHulme yes sir. same behavior with any PWA I try (dev.to, Instagram, Starbucks, etc) – Maurice Apr 9 '18 at 19:26
  • @Maurice It sounds kinda like a Samsung software-related issue then. You'd best stick to Samsung Internet or Hermit for this I guess.:) – owlswipe Apr 10 '18 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.