0

I've been trying to root my LG H500 (Android version 6) sporadically over the course of more than one year, with many combinations of software, each tried multiple times. None were effective. I had USB debugging enabled during all those attempts, and I also used a Windows 7 PC to connect the phone to.

USB drivers used (all of those were tested separately):

  • LGMobileDriver_WHQL_Ver_4.1.1
  • LG-Mobile-Driver_v4.2.0.0
  • LGUnitedMobileDriver_S51MAN313AP22_ML_WHQL_Ver_3.13.2
  • An LG United Mobile Driver less up to date than the one above that was recommended to me as compatible with my phone by the LG Mobile Support Tool, don't have the exact version at hand

All of the above were downloaded from sources as official as possible.

Most testing I did was with LG-Mobile-Driver_v4.2.0.0, under which I tried to install the drivers for as all the possible forms of connection between the phone and the PC. There were 4 modes:

  • Charge-only
  • MTP
  • PTP
  • MIDI device

The PC attempted to install drivers for each mode. All drivers were installed except for one or two drivers that failed to install under MTP mode. I exclusively used MTP mode for rooting the phone, by the way.

Drivers were also tried to be installed when the phone was off (but at the same time connected to the PC). None of these were installed successfully. One of those was "LGE Android MTP Device". Same problem appeared when I tried to set the phone to "Download mode".

Rooting programs used:

  • Kingo Root (latest version)
  • LG One Click Root (versions 1.3 and 1.2)
  • RootGenius

Kingo Root was always spiking from around 26% to 80% to 100% in mere seconds, then just gave me the "ROOT FAIL" message after it failed.

RootGenius freezed the phone while it was on, but a simple reboot fixes the problem. I used it only once and didn't bother afterwards.

LG One Click Root always gets stuck at 60% (Rebooting into download mode), but I do the reboot manually so no problem till now. Whether I actually go into download mode doesn't matter because the program says it "manages" to root my phone (goes at 100%). This is not the case, however, because Root Checker still says it isn't rooted. When I actually DO go into Download mode, it gets stuck at 0% with a small message underneath saying "Unknown B92" (the numbers change every time this happens).

What can I do from now onward? Are missing drivers causing a problem? Will maybe trying to root the phone on a connectivity mode other than MTP change anything?

  • Is that particular model root-able? Just because there are tools out there, doesn't mean they are designed to work on everything. – SiXandSeven8ths Apr 6 '18 at 18:13
  • @SiXandSeven8ths I don't know if it isn't rootable at all, only that it isn't rootable by Kingo Root and LG One Click Root (again, excluding RootGenius because it gave me a bad experience). However, the programmers of both say that my phone not being listed doesn't necessarily mean it isn't supported. Moreover, I used Kingo root on another not listed phone and it worked perfectly. – Corsaw Apr 6 '18 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.