4

I have been researching about this for quite some time and frankly I haven't found anything that reproduces this effect in any phone that I have tried, as you know there are a few system apps that manage to grey-out the "Disable" button in App info screen in Settings, at first I thought this was only limited to critical system apps but based on my research I know that this isn't necessarily the case as in some cases I found that some regular(no-critical) pre-installed system apps in some phones have this effect e.g Facebook, Weather, Facebook Installer, Email, Gmail etc. and there are even some malware apps that achieve this, these apps don't even appear to be in the device administrators list therefore they have to be using another approach.

I have tried all sorts of install locations in /system; app, priv-app, vendor (phones were rooted) but none have worked, factory reset doesn't change anything therefore it can't be some stored information in /data partition, which has led me to think perhaps has something to do with the app itself or there is some info of apps that shouldn't be disabled that the system uses without involving the /data partition (I highly doubt if this is the case).

I found a somehow related question here and another one on xda but no one gave a definitive answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.