3

So I've been having this issue for the last month+ and I have yet to find an answer. I have a Samsung Galaxy S6 running Android 7.0

My home wifi was working fine until one day, seemingly out of the blue, I started noticing my phone was not connected to wifi. When I would inspect the connection I see "authentication error occurred". I can put in the correct credentials and I still get the error. HOWEVER if I turn the wifi on my phone on and off it can auto connect to the router and will maintain a connection. So it appears the authentication error is not due to incorrect credentials. Sometimes I reboot the phone and that allows it to connect as well.

The phone has no problem with any other wireless access points and no other devices in the home have an issue with the router. I have other Android devices that don't have this problem.

I'm not even really sure what could cause this issue. Malware? Why would it only be between this specific phone and that specific router? Could anyone with some knowledge of networking be able to suggest what the problem could be?

  • 1
    Maybe you can gather more information through ADB, android's usb debugging interface, all you need is a computer with ADB installed and a usb cable to connect your phone, then adb logcat should show you any errors or warnings in realtime. – x13 May 21 '18 at 12:07
  • 1
    From search looks like something to do with Samsung devices specifically. Slightly off-topic...Do you have knox enabled? – xavier_fakerat May 21 '18 at 19:02
  • 1
    can you try connecting to Open WiFI Access point ? let us know. will be helpful to understand the issue. – Devidas May 22 '18 at 17:13
  • 1
    Also mention Security Type (WEP / AES /WPA2 etc.) used on router in question try using same security type on other router. – Devidas May 22 '18 at 17:16
  • 1
    Looks like a bug that messes up wi-fi config or peharps hardware fault, please try changing Wi-Fi to be on always during sleep.. – xavier_fakerat May 25 '18 at 11:34
0

Knox was the answer for me. Force Stop the Knox app and my tablet sprang to life. Phone did the same and my wife's Samsung tablet ran much quicker.

Settings -> Apps -> Knox -> Force Stop

New contributor
gazoid is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.