3

I have installed lineage os on a Samsung Galaxy S5. I tried to bring Link2SD to work. I gave it root access via the root add-on in lineageos. Link2SD complains about not being able to mount the 2nd partition which already had worked on a different Phone for the same purpose. I can unmount the second partition in Android settings and then it works, but after rebooting Link2sd can't mount the second partition, because the system already has mounted it.

How can I prevent Android from mounting the second partition before Link2SD can access it?

Android 7.1.2 Lineageos 14.1 20180411

  • if your 2nd partition is already mounted Link2SD should auto detect it is mounted and continue w/ rest of its job. fact that it complains makes me think its likely you haven't mentioned the current partition # in block device e.g./dev/block/mmckblk1p2 make sure p2 is in fact the 2nd partition and re-create mount script . in already mounted condition use the unmount 2nd part & remount option to see if that helps – user1874594 Aug 1 '19 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.