0

I've an Asus zenfone selfie with some version of android 6.0. A few days back my phone shutdown on low battery like it happens often. But ever since, its been going into a boot loop.

I've pretty much all of my important data (contacts, gallery, documents and downloads, gallery, WhatsApp data/history, chrome history) on internal storage. Unfortunately, I was not careful enough to do keep any data backup. I am desperately looking for solutions.

I've not been into rooting or hacking my phone till now. But this issue has had me searching desperately for solutions. This is where things stand as far as I can understand:

  1. Most of the time, the booting process just stays in the ASUS logo screen and takes forever. Once in a while, "Android starting optimising 1 of 13 apps" or "1 of 9 apps" etc. appear and then another screen "Android starting apps" appear and then the phone restarts again.
  2. Phone is NOT rooted. USB debugging is OFF.
  3. I can enter into standard recovery mode. But "add devices" don't show up anything.
  4. I tried wiping cache, that didn't help solve the problem. Haven't tried other options (such as factory reset/update from sd card) yet as I'm not sure if I can recover my data after that
  5. The phone shows up as MTP device when connected to laptop, but there is no accessible drive that appears and therefore I cannot open internal storage.
  6. Internet search brought up android data recovery apps like Dr. Fone, Easeus etc. Not sure if they work as I don't see them appearing in the mainstream/standard android/xda forums. I installed one of them, "Dr. Fone", but it could also not detect my phone/connect to it.
  7. A rare and curious thing happening is that very very rarely, after hours of trying, the phone very unpredictably gets into safe mode (if I've managed to keep holding the volume key down through the long boot sequence past the "starting apps" stage, even then not always, only extremely rarely). Its highly unpredictable and happened only 3-4 times so far. But every time, I tried to connect to laptop or insert SD card or copy data to computer or SD card or google drive, the phone again restarted.

What are the options I have?

A. Since I have access to recovery mode, factory reset is something I can do. But from most accounts, it seems to erase all data. I've been reading about these android recovery apps which will help you retrieve deleted/erased files. But since I don't see any of the mainstream android forums or platforms talking about these, I'm not sure if this is reliable option.

B. From recovery mode, I can try "apply update from sd card". If I were to try this: - Would I be able to retrieve my data after this? I couldn't get conclusive response on this on various forums. - If this is a safe option to try, how do I get a valid image that I can apply? I found this link from Asus.in website: http://dlcdnet.asus.com/pub/ASUS/ZenFone/ZD551KL/UL-Z00T-WW-21.40.0.2156-user.zip?_ga=2.18197885.576894828.1524419879-1959903817.1524419879 Is this a valid update image file I can use. How can I know?

C. I have been reading about CWM, TWRP etc. as custom recovery solutions with more options including data backup and restore. But I don't have these installed on my phone. I read that the phone has to be rooted to install them. Rooting the phone also seems to be an option with data loss. I'm not sure if these are options for me at this stage.

D. Not sure if there is a reliable way to reproduce safe mode. Even if that happens again, I'm not sure what I can do that will help recover data. Connecting to laptop, inserting SD card, trying to copy folders on google drive etc. have all led to instant reboot. Is there anything I can do to more predictably get into safe mode and is there anything I can do in safe mode to fix the problem?

E. Are there any other options I have?

Any help will be very valuable. Thanks.

Warmly Shaheen

  • Update: In one instance where booting in safe mode happened, I managed to enable developer options and turn USB debugging on. Adb devices still does not list the device. – Shaheen Apr 25 '18 at 2:28
0

I've had the same problem. I've installed TWRP using the instructions here (but the files I downloaded were others; pay attention to your phone version, model, etc).

After booting on TWRP your files can be accessed using your PC normally, so you can do your backup, reflash your boot.img (look for it online, follow instructions on the same website I sent) and do a factory reset via recovery mode.

Hope it helps you and other people online.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.