I am unable to view my Android device, an Oppo Find7, with ADB. I can view it with Fastboot. As I use a Mac, I followed this guide to install ADB and Fastboot.

More generally, I am having issues with my phone which is stuck on boot-loop and I can only access Fastboot (no bootloader or recovery working). I'm hopeful I can fix this once I get ADB working again! But if anyone knows if I can get the Oppo unbricking tool for Mac I would be very grateful :) I've only found it for Windows, and unfortunately, the official Oppo support forums no longer exist.


Fastboot getvar all

gives me


Not a good sign I think.

Thank you!

  • Fastboot and ADB require different drivers, and situations alike yours (and opposite) are quite common. I can say it for sure only for Linux/Windows use-case, but with high probability for Mac the point is the same. Try different drivers.
    – Suncatcher
    Apr 24, 2018 at 12:00
  • You didn't explicitly mention it, so to verify: You are aware that ADB cannot detect a device in fastboot/bootloader more – and fastboot cannot detect it in modes other than that? So when fastboot can detect it, ADB naturally cannot.
    – Izzy
    Apr 24, 2018 at 13:44
  • I was not aware, so perhaps as I am stuck with only access to Fastboot on the device this would explain it! Thank you. What confuses me is I thought I used to be able to use Fastboot to switch into ADB, but perhaps I was mistaken. @Suncatcher I believe I have the latest versions of both drivers, having followed the guide linked in my question to freshly install. Is there an easy way I can check if my drivers are correct and up to date?
    – Shadician
    Apr 24, 2018 at 14:32
  • Actually, I missed the point with the bootloop. If you had not enabled ADB before bootloop, then you cannot access it now. As Izzy correctly said, fastboot/adb modes are not interchangeable, and though you can switch to fastboot from adb (reboot bootloader), the opposite thing is impossible.
    – Suncatcher
    Apr 24, 2018 at 15:38

1 Answer 1


EDIT: To begin with you should probably install adb/fastboot directly from Google. This is the best way to update/maintain adb/fastboot.

So you state that you have no access to the bootloader, yet you are able to issue fastboot commands and invoke at least some type of response? Then that means you have access to your bootloader my friend. Fastboot == bootloader (or Download Mode, which is essentially still bootloader). I've never had a chance to mess with your specific model, but if you're stuck in a bootloop I'd suggest trying to issue a few more commands:

fastboot flashing get_unlock_ability

this will let you know if you can unlock the bootloader

fastboot flashing [unlock] [unlock_critical]

one of these will let you unlock the bootloader (as long as nothing else prevents it from doing so)

And if you're able to unlock it, I'd suggest downloading TWRP for your device (Google = best friend), and flashing it to your phone with a

fastboot flash recovery [twrp.img]

Bricks aren't ever really a permanent mess-up, as long as you can get into some type of recovery. Even if you can't get it unlocked or flash, you may be able to boot still with a factory image (Google = best friend), then try flashing the full firmware, if it wont take, extract the boot image and see if you can force it to boot with

fastboot boot [boot.img]

let me know if any/none of these work and we can go from there. best of luck.

  • 1
    Most phones needs a unlock code from vendor to unlock. And it's hard to get... Apr 25, 2018 at 2:52
  • Actually "most" phones don't require much of anything at all outside of enabling OEM Unlock. I'll admit for sure that there are plenty of models (ahem carriers) that require this, but for the most part I've only had a small handful of devices that I was never able to bootloader unlock. Apr 26, 2018 at 1:02
  • No luck! 'fastboot flashing get_unlock_ability' fails to do anything but load continuously (displays '...'). I left it for over 3 hours with no change. Same with 'fastboot flashing [unlock]' or with '[unlock_critical]'. Flashing the recovery is something I have attempted many times before and while it seems to work, I am never able to access recovery mode after the flashing completes. This worked for me on the same phone a few years back, so it's weird I have this problem now. Sorry, but thank you for the suggestions!
    – Shadician
    Apr 26, 2018 at 11:08
  • i didn't mean literally to use [unlock] or [unlock_critical]... I just used the brackets to mean that those two could be interchangeable within the same command. Guess I should have specified better. The syntax of the command is fastboot flashing unlock and/or fastboot flashing unlock_critical. At least these are the commands for more recent versions of fastboot; though if you're model is a little older then the command you need would be fastboot oem unlock. Note that my use of brackets '[]' in any of the above shouldn't actually be included in your commands, just whats inside of them. Apr 28, 2018 at 7:28
  • I should have been clearer in my reply, I was also using the square brackets to show I tried both interchangeably, so my fault! Neither of them had any effect. I've tried fastboot oem unlock previously and I think it gave me a positive response, but I was still unable to successfully flash and open TWRP.
    – Shadician
    Apr 28, 2018 at 10:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .