My brand new out of the box Moto G6 won't send or receive SMS. I'm using the official SMS app which has SMS permissions (triple checked this) and is the default SMS app.

I tried everything: cleaning cache, reinstalling, updating, rebooting, turning off both SIM cards, rebooting the radio through phone commands, etc. Nothing worked.

How to fix this?


After installing another generic SMS app and seeing it was receiving and sending SMSs, I uninstalled it and opened the official SMS app and it worked.

It makes no sense but I'm posting here to help.

And yes, the official SMS app was setted as the default SMS app AND had SMS permissions.

  • It might be that the phone hadn't received the SMSC/MMSC settings yet from the carrier - strange that the other app would possibly force it to or it was just timing. Glad you got it working!
    – JGlass
    Apr 25 '18 at 19:53
  • I forgot to mention that 4G and phone calls were working! Apr 25 '18 at 21:25
  • Phone calls and data are different than SMS, at least with GSM networks - the phone needs to be set to use a specific SMSC (Short Message Service Center) phone number that the carrier sends to the device which then relays messages on behalf of the cell phone.
    – JGlass
    Apr 26 '18 at 14:47
  • To confirm... I had the same problem today with a brand new Moto G6 plus. No receiving and sending of SMS with the standard app. Installing another app worked. Removing that one... the standard app also kept working. As a sidenote: the SMSC number is still missing when I dial *#*#4636#*#* (see this answer) but at least it is working.
    – Rik
    May 12 '18 at 18:00

Had the same problem. Turned out that the default SMS app didn't have the phone number entered in the app's settings (in the SMS app click the 3 dots, then Settings then Advanced, then Phone number). Once the phone's number was added - text (both send and received instantly started working). Hope this helps others!

Not the answer you're looking for? Browse other questions tagged or ask your own question.