0

I was able to connect my android mobile to my computer as I enabled USB debugging from the developer options. I used to receive the USB debugging permission alert and from there I switch from charging to file transfer.

All of a sudden and while my device is having a low space problem, the USB debugging permission alert stopped appear when I connect it to my PC. That means I can not connect him to my PC as I can not give the permission as the default is charging. I tried two different PCs (Ubuntu based, and Windows 10 based) with no luck as well as two different cables. I used another android phone with the same cable and to the same PC and it connects OK.

My mobile has an Android version of 4.4.2 and updates stopped a while ago. My other mobile (Android 7.0) is connecting with no problem. I connected several times before from this mobile with no issue.

I tried to restart the mobile and switch off and on the USB debugging option with no luck. I am trying to connect it to my computer to take some backup and free some space.

Here is the information of my mobile:

  1. Huawei Honor 4C CHM-U1
  2. Memory at the current time: 391 MB Free 8 GB total
  3. Android version of 4.4.2

Can any body help me how to fix this?

  • Just for clarification: Are you only worried that the alert no longer appears – or can you no longer connect that device to a computer at all? In the latter case: have you tried a different cable as well? And does charging still work via the same port? – Izzy Apr 26 '18 at 6:11
  • I added more clarification to answer your question. I can not connect the mobile unless the notification appeared, and yes I used two different cables, I even used another android mobile with the same cable and it worked fine. – aibrahim Apr 26 '18 at 8:44
  • Ah! You mean the notification about USB connection – which you'd then tap and select the connection mode? If it's that, please try the following: With the cable connected, go to Settings › Storage and see if there's an option to switch connection mode. Some devices have this setting in Settings › Development ("chose USB configuration" or similar item). Let us know if you found something and which action helped (if any). – Izzy Apr 26 '18 at 8:53
-1

It was a hardware problem. When I pushed the cable hard into the port, it connected. I will need to fix the port. Thanks for the support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.