0

My SD card suddenly stopped working in my Motorola Moto E2, running Android 6.0. When I insert it, it just says "checking..." for ages, then says that it's not inserted. I then removed the card and told Android to forget the SD card. When I insert it now, it tells me that it's in an unsupported format. I try to format it, and I get an error as shown in the picture below (apologies for the size!)

I previously had it formatted as internal storage, and had various apps installed on it. I've tried for format it in my computer, but it is read-protected. I've gone through all the methods online to remove read-protection (specifically using regedit and diskpart), but neither have been successful. I've got AOMEI Partition Assist, but that doesn't even see the SD card. When I plug the SD card in, my computer can see the drive (and data on it), but is in read-only so won't format.

I've also tried MiniTool Partition Wizard, but, while it sees the SD card, since it is read-only the wizard can't do anything with it.

Any assistance would be most appreciated! (and if anyone knows how to make the screenshot below smaller, feel free to edit this question to do so!).

Screenshot of error

  • 1
    Be careful if your SD card suddenly refuses to write. Is is often an indicator that the contained flash memory is about to fail. Backup your data and replace the SD card. – Robert Apr 27 '18 at 18:37
  • It's not so much that it's refusing to write, just that it's in write-protect mode. Were it the case that it weren't in write-protect mode, just failing to write, then I'd agree, but this is a genuine Samsung Evo card, that I haven't had for all that long. – Sam T Apr 27 '18 at 20:49
  • Becoming write-protected is the symptom that indicates the card is about to fail. Please do not crosspost, it's against SE rules. – user252482 Apr 28 '18 at 4:43
  • Of course it is possible that it is about to fail. However, I have only done a few tests, and so it's a rather negative outlook to troubleshooting to try a couple of basic things then throw in the towel =P -- I was hoping for assistance from people with more knowledge than myself by coming here – Sam T Apr 28 '18 at 5:49
  • If Windows is just unable to "reset" the sd-card there is still the option to overwrite the first few megabytes using a disk wipe software. Just overwrite it with zeros and abort the process after a few seconds. Then disconnect and reconnect the sd-card. Windows should then ask to format it. – Robert Apr 28 '18 at 10:15
0

Full-sized SD cards have a physical write-protect tab. The adapter for your microSD might have one. Make sure it's in the correct position.

enter image description here

  • Thanks for answering, but if you see the OP then it says that I have tried the standard online solutions. Would I maybe be better asking this on Superuser, do you think? More the crowd, since it's really about the SD card, just that I formatted it with an Android system – Sam T Apr 27 '18 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.