0

Two months ago I opened a similar thread (click) but now the problem's gotten worse. Please bear with me, I know there are a lot of threads about the same problem but I've tried everything suggested in them to fix it but the only thing that helps (at least temporarily) is restarting the PC.

I used to use the S7 (7.0/Nougat) with a Windows 7 PC and everything was working fine. Now I'm mainly using it on a Win 10 PC and every time I connect it via USB cable, a "give permission to open MTP connection" message pops up (it only ever did it once with my Win 7 PC).

The problem is:

Sometimes this message doesn't pop up and then neither Android Studio nor Eclipse can see the S7 - it doesn't show up in the "Android Profiler" (AS)/"Devices" (Eclipse) tab and I can't run any apps through them on it. There's also no "Samsung Galaxy S7" entry in the Windows Explorer (not sure if it's charging) and Kies doesn't see it either.

The only thing that helps is restarting the PC:

  • About 50% of the time it then installs a Windows update
  • As for the other 50%: It doesn't say anything about updates but rebooting usually still takes twice as long as normal and it's showing the black screen with the blue spinning circle-dots for at least one minute before it switches to the login screen

What else I've tried so far but never helped:

  • Restart the S7
  • Kill and restart ADB (through Eclipse and command line - said "daemon not running; starting now at tcp:xxxx", then "daemon started successfully" every time)
  • Disable and re-enable Developer Mode
  • Disable and re-enable USB-Debugging
  • Change connection mode to PTP and back to MTP
  • Set to "always prompt to pick device" instead of "automatic" in Eclipse (Run - Run Configurations - Target) - it's now back on "automatic"
  • Different USB port
  • Different USB cable
  • I installed the Google USB driver through the SDK Manager when I started using Win 10 but Eclipse stopped detecting the S7 after restarting the PC, so I uninstalled it again and have been using the driver Win 10 found since then
  • Install Kies

Does anyone know how to keep this from happening?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.