2

Moto X4 running Android 8.1.0. Attempts to connect the phone to any of my Windows 10 PC fail. The phone begins to charge but under Settings, USB says Not Connected. The phone does not appear in Device Manager on the PC. A Moto E4 running Android 7.x works without issue, allowing me to see files on each internal and SD.

  • AFAIK The X4 has USB-C and the E4 uses Micro-USB, therefore you are using two different USB cables. Make sure you are using the original USB-C cable or if it is the one causing trouble try a different one. – Robert May 16 '18 at 19:08
  • @Robert I tried the original USB-C cable (Which did work once before with the same computer) as well as the same Micro-USB cable with a USB-C adapter. I have an additional USB-C cable on order as well. – Mooseman May 17 '18 at 11:49
3

There are reports that the update to 8.1 has disabled USB storage functionality but there is a fix on the way (time table unknown). The only work around right now is to disable your lock screen, reboot, then you can connect it. This worked for me but it will stop working again as soon as you re-enable your lock screen (which obviously everyone should).

Sorry, but long story short, the update broke it and you'll have to wait for a fix.

A Motorola agent confirmed the issue on the official Lenovo forum

  • The latest security patches released in June corrected this issue. – Mooseman Jun 17 '18 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.