1

the google play store won't open or download certain apps. most apps open fine and have no problem downloading updates, but a few are giving me trouble and not even letting me open their page on google play, giving an error that there's no internet connection, even while other apps are actively downloading updates.
i've tried clearing cache and data from the apps several times, cleared the phones cache, ensured the accuracy of the date and time on the phone, removed and re-entered my google account, made sure gmail was updated, uninstalled google play updates, and even reset the phone to factory settings and reinstalled everything... and still have the same trouble with certain apps.
the best i've been able to manage was after uninstalling updates to google play i was able to view the apps pages on the old version of google play and install them, but after google play updated i couldn't update the apps, and the versions installed were not the current versions for some reason.
the apps affected include google play games, google play books, google calendar, facebook, and a game i'm trying to get back into summoners war. i'm sure there are others that wouldn't work either that i didn't check. every time i try to go to these apps pages on google play or update them in my apps i get the same error about no internet connection, even while other apps are currently downloading updates.
why would this happen only for certain apps and how can i fix it?

  • What networks have you tried it on? – Dan Hulme May 23 '18 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.