I have an unlocked Nexus One that I rooted to remove a system application (Twitter), but now the OTA system update fails with the message

Verifying current system ...
assert failed: apply_patch_check("/system/app/Twitter.apk", "<long hex string>")
E:Error in /cache/c8847c98b948.signed-passion-FRG83-fromFR91.c8847c98.zip
(status 7)

Un-rooting the device doesn't seem to fix this. Is there more to removing a system app than doing a 'rm' of the .apk? For example, is there some configuration file that also needs patching?

2 Answers 2


It looks like you need to re-add the Twitter.apk, update, then remove it again. Have you tried that? The patch itself is trying to find that apk for the update (not sure if you can change the patch since it is probably signed?).

  • From what I've read, the system update removes the exploit which allows rooting the phone in the first place. My hope was to remove the app while rooting the phone was still possible.
    – ctuffli
    Commented Oct 6, 2010 at 20:13
  • HA! Those bastards. Don't worry there are exploits to root it and to replace the recovery as well for the OTA. www.unrevoked.com Commented Oct 6, 2010 at 21:50
  • I tried re-adding Twitter, but the update still fails with the same error.
    – ctuffli
    Commented Feb 9, 2011 at 16:26

What ended up working was re-installing the stock Nexus One (a.k.a. Passion) image. There seem to be several different ways to go back to a stock installation, but what worked for me was:

  • Download the PASSIMG_Passion_.zip file from shipped-roms.com
  • Re-name the file passimg.zip and copy it to the SD card via USB
  • Booted into hboot (hold the volume down button while powering on the phone)
  • Selected 'yes' when asked if hboot should install the image

The above steps were inspired by this post in the XDA-Developers forum. After doing this, OTA updates started working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .