0

I have a moto g4 plus android 7.0 for which I have unlocked the bootloader and I have flashed twrp and ran root.bat. After installing supersu, I have wiped the cache and dalvik and tried rebooting the system but it takes the phone back to the twrp main page. I have tried to start through the bootloader menu too but the same thing happens there too. I have also tried echo systemless and magisk. how do I boot back into android 7 with root privileges?

1

Clearly your changes have broken your Android system partition. You need to re-flash the stock Android system image for your phone.

  • This is likely the best answer, the reason is pretty common actually... The command to flash TWRP on this (and many other) devices is 'fastboot flash recovery twrp.img' but it is not unheard of to forget "recovery" parameter in the command, placing TWRP in the boot partition, which results in exactly the behavior described – acejavelin Jun 14 '18 at 15:51
  • @acejavelin It would be good to write that as an answer. It's a good explanation and more specific than what I wrote. – Dan Hulme Jun 14 '18 at 17:45
  • it's more an explanation of the cause, but not an answer to the problem. – acejavelin Jun 14 '18 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.