1

I get several thousand entries a day of the NlpWakeLock under Google Play Services (I'm using Wakelock Detector Free). It's draining my battery significantly. I have found it occurs when I'm connected to WiFi (I'm certain about my home WiFi, will check with the university WiFi) and not when connected through mobile data or not connected to the internet at all. I have also ticked off all options in the Location Services sections in Settings. What do you think is going on?

Please, also note that I'm aware of solutions according to which you reduce or completely stop the wakelock. However, before doing that, I would rather try to figure out what's going on. Thank you.

UPDATE: I'm on Android Jellybean.

UPDATE #2: It seems like my download speeds on my phone are very low compared to other times. Just in case, I downloaded an antivirus to do a virus scan. It didn't find anything.

UPDATE #3: I tried disabling find my device, as well as re-adding my Google account and removing two other email accounts. The problem was not solved.

UPDATE #4: I tried the University WiFi, the problem remained.

EDIT: Added the wakelock doesn't appear when offline.

UPDATE #5: I tested it on a third WiFi network, the problem remained.

0

Well, I tried enabling some of the Location options in Location services, the "Google's location service" and the "Location and Google Search" option, to see if that would fix the issue. I enabled them and the wakelock issue disappeared. I disabled "Location and Google Search" at first and then "Google's location service" and the issue was still gone. All Location Services are now off and the nlpwakelock appears at logical rates. My download speeds are higher as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.