2

With TWRP, on almost every operation I get

Failed to mount '/preload' (Invalid argument)

My device currently can not boot, and this may have something to do with it, /preload is currently in /etc/fstab, I can see the entry here with

/dev/block/mmcblk0p16 /preload ext4 rw 0 0

When I try to mount it, I get

mount preload/
mount: mounting /dev/block/mmcblk0p16 on /preload failed: Invalid argument

Is there anyway to fix this problem?

From my recovery.log, I have

/preload | /dev/block/mmcblk0p16 | Size: 0MB Used: 0MB Free: 0MB Backup Size: 0MB
   Flags: Can_Be_Mounted Can_Be_Wiped IsPresent 
   Primary_Block_Device: /dev/block/mmcblk0p16
   Display_Name: preload
   Storage_Name: preload
   Backup_Path: /preload
   Backup_Name: preload
   Backup_Display_Name: preload
   Storage_Path: /preload
   Current_File_System: ext4
   Fstab_File_System: ext4
   Backup_Method: files

I'm trying to flash LineageOS, but I'm really just curious about resolving this error message.

14
  • What about flashing full firmware with Odin ? – esQmo_ May 26 '18 at 5:57
  • @esQmo_ you mean flashing Lineage OS from Odin? Is that even possible? – Evan Carroll May 26 '18 at 15:26
  • You haven't mentioned anywhere that you were running LineageOS – esQmo_ May 26 '18 at 15:27
  • I'm not, I'm trying to run it. I also didn't mention that I was trying to run OEM which afaik is the only rom that Odin can flash? – Evan Carroll May 26 '18 at 15:38
  • Right. So go on and flash stock firmware through Odin – esQmo_ May 26 '18 at 15:43
0

I have this problem too, but I can install treble roms, I installed Lineage 17.1 without problems but sometimes I see the message / preload invalid argument, size of partition 0, I am looking for a solution but this error does not disturb my device at all

in xda i encontered this => All you need to do is go to official download page, download your official latest rom and flash Download the most recent firmware and flash in Odin. (There is instructions on how to download the correct firmware in the post)

0

try the same for /preload https://forum.xda-developers.com/android/general/how-to-fix-unable-to-mount-data-t3830897

it worked for me

1
  • Welcome to Android Enthusiasts! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies. For further hints, please see: How do I write a good answer. – Izzy Jun 12 '20 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.