2

I have a Lenovo P2 (42a) with Android 6, which I tried switching to Lineage 14.1, as my carrier hasn't provided any security/OS updates since 2016. I have previously done this with my old Motorola Moto G from Android 5.

I took a backup with adb (under linux mint), using the -system and -all options.

I unlocked the bootloader.

I flashed/booted TWRP 3.2.1.0 for this phone ("kuntao").

I transferred zip files. At one point the phone switched off while transferring with TWRP having mounted the "Internal Storage" partition, but it appears I got all things over on second attempt. It seems that sometimes TWRP gets stuck if the screen switches off while it is doing something, but the timeout can be increased if that is really the case.

I flashed the Lineage OS 14.1 file for the P2 ("kuntao").

I tried flashing the stock GApps zip, it let me know this was the version for 14.0 and I needed a different GApps file.

I then started over, flashing the Lineage OS 14.1 file and the GApps zip for 14.1 (Android 7.1). This would stop in various places, at least 3 different ones.

I then started over with the Lineage OS 14.1 file and the micro GApps zip for 14.1.

This completed, but when booting I get a black screen, a single long vibration and a continuously blue LED. The phone cannot switch off, only restart into bootloader or recovery, which at least isn't the worst news.

My adb backup does not restore - if I try this under TWRP, it seems to react to it, but get stuck, although with the screen on. When the command line process finishes, the result is the same as above.

Only issue I know of is that the provider can have added a few features, so that the flashing of the 14.1 file doesn't work exactly as intended. That would mean I need a complete image for Lineage OS or an image to restore to the "standard" Lenovo P2 state, as indicated here and here.

Any good ideas/procedures? Thank you.

0

OK, fixed - in the end I did this:

Tried "flashback" to stock android 6 with this zip file.

That didn't just work, so I tried with the automated script "flashall" in the zip.

That failed for the partition/image prov/prov32.mbn with the error message: FAILED (remote: Do not allow to flash Bootloader image on Unlock device)

I then went into the PRODUCT_CONFIGURATION_KUNTAO_ROW.xml file and looked at the command list.

I then executed all remaining steps except the ones to delete partitions, for instance

<KUNTAO_ROW_IFLASH>
...
<step operation="flash" filename="prov32.mbn" partition="prov"/>
(first failure in script)

<step operation="flash" filename="sbl1.mbn" partition="sbl1"/>

became

fastboot flash sbl1 sbl1.mbn (failed with same error)

<step operation="flash" filename="sbl1.mbn" partition="sbl1bak"/>

became

fastboot flash sbl1bak sbl1.mbn (worked)

and so on all the way through, but skipping the instructions to erase (although I would have done it if the phone didn't start up). It did and I now have ROW (Rest Of World or normal) firmware rather than a carrier-specific version blocking OTA updates due to compatibility with one of their own apps.

I could then pick up a series of normal OTA updates from Lenovo, including Android 7, so I now don't need Lineage OS to get an upgrade for this device (at least not before they do an official Android 8 ROM for it :) ).

<step operation="flash" filename="rpm.mbn" partition="rpm"/> - didn't work
<step operation="flash" filename="rpm.mbn" partition="rpmbak"/>
<step operation="flash" filename="devcfg.mbn" partition="devcfg"/> - didn't work
<step operation="flash" filename="devcfg.mbn" partition="devcfgbak"/>
<step operation="flash" filename="lksecapp.mbn" partition="lksecapp"/>
<step operation="flash" filename="lksecapp.mbn" partition="lksecappbak"/>
<step operation="flash" filename="tz.mbn" partition="tz"/> - didn't work
<step operation="flash" filename="tz.mbn" partition="tzbak"/>
<step operation="flash" filename="keymaster.mbn" partition="keymaster"/> - didn't work
<step operation="flash" filename="cmnlib.mbn" partition="cmnlib"/> - didn't work
<step operation="flash" filename="cmnlib.mbn" partition="cmnlibbak"/>
<step operation="flash" filename="cmnlib64.mbn" partition="cmnlib64"/> - didn't work
<step operation="flash" filename="cmnlib64.mbn" partition="cmnlib64bak"/>
<step operation="flash" filename="emmc_appsboot.mbn" partition="aboot"/> - didn't work
<step operation="flash" filename="emmc_appsboot.mbn" partition="abootbak"/>
<step operation="flash" filename="logo.bin" partition="logo"/>
<step operation="flash" filename="NON-HLOS.bin" partition="modem"/> - didn't work
<step operation="flash" filename="fsg.mbn" partition="fsg"/>
<step operation="erase" partition="modemst1"/> - skipped
<step operation="erase" partition="modemst2"/> - skipped
<step operation="flash" filename="adspso.bin" partition="dsp"/>
<step operation="flash" filename="boot.img" partition="boot"/>
<step operation="flash" filename="recovery.img" partition="recovery"/>
<step operation="flash" filename="systemchunk0.img" partition="system"/>
<step operation="flash" filename="systemchunk1.img" partition="system"/>
<step operation="flash" filename="systemchunk2.img" partition="system"/>
<step operation="flash" filename="systemchunk3.img" partition="system"/>
<step operation="flash" filename="systemchunk4.img" partition="system"/>
<step operation="flash" filename="systemchunk5.img" partition="system"/>
<step operation="flash" filename="systemchunk6.img" partition="system"/>
<step operation="flash" filename="systemchunk7.img" partition="system"/>
<step operation="flash" filename="systemchunk8.img" partition="system"/>
<step operation="flash" filename="systemchunk9.img" partition="system"/>
<step operation="flash" filename="systemchunk10.img" partition="system"/>
<step operation="flash" filename="systemchunk11.img" partition="system"/>
<step operation="flash" filename="systemchunk12.img" partition="system"/>
<step operation="flash" filename="cache.img" partition="cache"/>
<step operation="erase" partition="userdata"/> - skipped
<step var="config bootmode factory" operation="oem"/> - skipped

EDIT: On the plus side, I just got the newly released Lineage 15.1 ROM to work for this phone.

  • i am getting the same error but not getting how to fix it. black screen with blue led. Please help me. I didnt understand your fix for the error you have posted. – Rahul Khairnar Jun 1 '18 at 13:33
  • Lenovo P2 and which starting and ending Android/Lineage version, please? I dare only give advice if it is the same case as there is a risk of damaging the phone firmware. – nsandersen Jun 2 '18 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.