1

I know there are a number of questions on similar topics but I believe my issue is different, let me explain:

I'm in Spain where the carriers do allow usb tethering of wifi connections (the phone is connected to a wifi network and I'd like to tether this connection via usb to my laptop so the laptop uses the wifi connection of the phone). I know this is possible because on my samsung galaxy note 1 with android 4.4 I can do it, no problem.

With my new samsung galaxy note 4 (unlocked, originally t-mobile) with android 6.0.1 if I have an active wifi connection and turn on usb tethering a popup tells me that

Attention

Wi-fi is turned off when usb tethering or mobile hotspot is active.
To turn on wi-fi please turn off usb tethering or mobile hotspot.

So basically I have to choose between wifi and usb tethering, can't have both. I can only tether the mobile data not the wifi connection.

The phone is rooted so I tried a couple of things I found on stackexchange and xda-developers:

Modifying the settings database (as root):

settings put global tether_dun_required 0
settings put system tether_entitlement_check_state 0

Adding this to /system/build.prop (as root):

net.tethering.noprovisioning=true

But still no luck :(

To be sure it's really the OS which is doing the blocking, not the carrier so on a rooted phone I should be able to go about it I guess.

It would also help if I could figure out which process is the one which actually does the blocking and then I could go after that somehow. Is there a way to figure this out?

  • You've to root your phone, Install magisk and install hotspot fix module – Hunter-X Jun 7 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.