This is the same to this question: Can't delete file in download folder

But for me, the answer is not clear, as per the OP's answer 'he turned on the SD Maid app' but did not state what option in SD Maid resolved the issue. The OP stated as well 'he deleted the whole directory' but not specified if using SD Maid or PC.

We have the same scenario where I redownloaded the same file, and after copying it to the exact location where I'm having an issue, it made two identical files and what I tried so far:

  1. Highlighted both items and deleted them using SD Maid, it says success but after a refresh, it retains the other file with 0 bytes.
  2. Connected my phone to PC as MTP and tried to delete it from there. What I noticed is it only shows one file, unlike looking in any Android file manager. It says success but checking it again on the phone it retains still the file with 0 bytes.
  3. Tried apps in Play Store that says secure delete that uses a different algorithm but still, after it says yes, the same scenario occurs above.
  4. Perform wipe cache partition in the stock recovery.
  5. Clear data and cache of stock file manager.

I know my last resort would be a complete factory reset, but is there any other way?

2 Answers 2


I found a pretty easy fix: Deleting storage and cache from the system app "media storage" and then restarting made the 0 byte files disappear for me


I installed the SD Maid app despite knowing that it didn't delete the problematic file. But at last, I removed the whole folder with the app, and it finally worked. Then I tried to delete the folder by the file explorer of my phone, and everything except the problematic file got deleted. Then I deleted the folder (with the 0b file in it) with SD Maid.

Note that before doing this, I've also tried using force delete on Windows Explorer and ADB Shell, but none worked.

  • 1
    Hi, though this question is almost a year already. Yea, that method works if the 0 byte file is inside a folder. But in my case it's in the root of the storage, it's not inside any folder. I just resolved it by doing factory reset, though it was not my preferred method. Mar 18, 2019 at 1:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .