1

This is the same to this question: Can't delete file in download folder

But for me the answer is not clear, as per the OP's answer 'he turned on the SD Maid app' but did not stated what option in SD Maid resolved the issue. The OP stated as well 'he deleted the whole directory' but not specified if using SD Maid or PC.

We have the same scenario where I redownloaded the same file and after copying it to the exact location where I'm having issue it made two identical files and what I tried so far:

  1. Highlighted both items and deleted it using SD Maid, it says success but after refresh it retain the other file with 0 byte.
  2. Connected my phone to PC as MTP and tried to delete it from there and what I noticed it only shows one file unlike looking in the any Android file manager. It says success but checking it again in the phone it retain still the file with 0 byte.
  3. Tried apps in playstore that says secure delete that uses different algorithm but still after it says yes the same scenario occur above.
  4. Perform wipe cache partition in the stock recovery
    1. Clear data and cache of stock file manager

I know my last resort would be complete factory reset, but is there any other way?

0

I was having this exact same issue with two phones. Which I smashed the first phone on the floor with anger.
I tried everything like, using force delete on Windows Explorer AND ADB Shell, but none worked.
Then I installed the SD Maid app despite of knowing that it didn't delete the file I wanted.
But at last, I removed the whole folder with the app, and it finally worked.
But, I tried to delete the folder by the file explorer of my phone and everything except that annoying file got deleted. Then I deleted the folder (with the 0b file in it) with SD Maid.
Hope this helps.

  • 1
    Hi, though this question is almost a year already. Yea, that method works if the 0 byte file is inside a folder. But in my case it's in the root of the storage, it's not inside any folder. I just resolved it by doing factory reset, though it was not my preferred method. – threeFatCat Mar 18 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.