0

I have a Samsung Galaxy J7 Pro SM-J730GM purchased at a Sanborns shop in Mexico, running Telcel's stock ROM, rooted, with TWRP recovery and Link2SD. A couple weeks ago I repartitioned my SD card in order to use Link2SD's app linking function. I remember having to reboot my phone a couple times before it picked up the card, but at the moment I thought it had finally worked. However, apparently it was just a fluke, because today I restarted my phone in order to flash TWRP, and when I started my phone back it didn't detect the card anymore.

The card is fine, as it can be read with no problems on a PC running Linux. The card reader is fine too, as the card is legible from TWRP and can be formatted without a hitch from Android. With that in mind, I tried formatting the card using my device's Set Up function, then I repartitioned it with my computer. When I inserted the repartitioned card, that's where my phone began refusing to mount it.

Has anyone had any luck mounting a partitioned SD card on this model? Am I going to have to flash an aftermarket ROM into my phone?

(PS: I'm going to try to reproduce it with a different card)

  • What format's did you make the partition's? – Bo Lawson Jun 6 '18 at 20:18
  • Partition 1 is FAT32, partition 2 is Ext3. – RAKK Jun 15 '18 at 4:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.