3
  • I got my new Android phone.
  • I added my personal GMail account to the Gmail app which synced my ~100 personal contacts from Google.
  • I installed WhatsApp.
  • I installed Outlook for Android.
  • I added my work mail account and did not uncheck "sync contacts" before first sync.
  • Only after I saw the ~100k work contacts in my phone I disabled "sync contacts" for my work email and as far as I see, all work contacts were correctly removed from the Android contact list.
  • However, in WhatsApp some of them (presumably those with a mobile number and WhatsApp) are still visible.
  • I tried the "Refresh list" option in WhatsApp, but they are still visible.
  • Also, there are no chats with these "contacts", since the contacts only got onto my phone by accident and they don't have my mobile number.
  • It seems I am not the only one.

Why are they still visible in WhatsApp and how can I get rid of them?

2 Answers 2

2

Even I had the same problem. I removed all the contacts from my phone address book but it would still show in my Whatsapp. Finally I figured it, though the phone address too does not show the contacts, if auto sync is on, it will still show. In my Phone, I went to Phonebook → Open Account settings → and turned off Auto Sync. That worked. Hope it helps.

2

I had the same problem. A deleted Android contact showing in WhatsApp (and in Signal too!), WhatsApp refresh method not working, etc. After digging around a bit, the solution was to uninstall Signal. That got rid of WhatsApp contact too. Now I have to reinstall Signal...

1
  • Thanks!! Signal was indeed the root cause for those shadow contacts on my WhatsApp. This had been bugging me for months.
    – GDumphart
    Jun 11, 2023 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .